Help - Search - Members - Calendar
Full Version: No Sound Mandrake 9.2
Linuxhelp > Support > Technical Support
hkufahl
I have had no luck in attempting to get sound with this card. I do not seem to have any sound system setup. Card is recognized, but at boot the following message is displayed,
Error while initializing sound driver, devise /dev/dsp can't be opened, (no such file or directory)
I also do not have any working mixers.
I have attempted to add sound card info into modules.config, using kwite, but recieve a no permission to save the file.

Any help would be appreciated!

PS Harddrake for this card does not work, clicking the config tool does not open the config file!
hughesjr
Check out this thread, starting on page 2....

If it is the same card, those instuctions should work!
hkufahl
Thanks! I will give your instructions a try and let you know how I come out.
hkufahl
I finally attempted your detailed instructionshere is where I am.

at the
Make step, I get the following error
no rule to make target /lib/modules/2.4.22-21mdk/build/include/linux/version.h , needed by au_vortex.dep Stop

Help if you can
Thanks
Jim
We need to go back to where you typed in the line

cd/src/linux

With out have a forlder with the src code in it it's very hard to partch drivers in. You seem very new so let me explain a little here. The src directory stands for source, it contains source code, or line for line program information, on many key programs in your system, including the OS itself. Sometimes the src code is stored in a more specific folder like linux.2.4 or something sybolizing what build it is. But programs will usually only look in the linux folder.

What you are going to need to do is link what ever folder has the mandrake souce code in it to a new folder named linux. Unfortunetly I don't believe that Mandrake leaves their source code in the src folder by defualt. type in the following lines and post the results...

Make sure you use the "cd .." comand to back yourself out all the way. "cd .." takes you one level up in the folder system. If you are logged in as root you should only have to do it ounce, if you are in as a user you make have to do it a couple times. Either way get all the way out to the top directory or "/" directory. Type ls to see a list of everything in the directory. You should see src. Than type in

cd src

This changes your directory to src. Now type ls again. Post what prints out.

Goodluck.
hkufahl
The directory is

/usr/src
and there are the following in it
aureal-1.x/ aureal.tgz linux@ rpm/

Linux is white text in a red box and it is flashing
hughesjr
What you need to do is to configure urpmi and install the kernel-source ... it doesn't require you to be a member. Without the kernel-source, you can't make kernel patches.

I detailed how to setup urpmi and how to update mandrake to the latest kernel in the linked post...specifically, starting here ... do the optional step and the required steps...except the newest kernel is now different....it is now kernel-2.4.22.28mdk

So substitute 2.4.22.28 for wherever you see 2.4.22.21 in the original thread....
hkufahl
OK, so far so good. All updates installed, new aureal.tgz downloaded and installed.

Make install returned the error

No rule to make target 'install' Stop

Now what?

Thanks
hughesjr
You should be in the directory:

/usr/src/aureal-1.x

if you are ....

I modified the original file specifically for an au8810 (because I couldn't compile it for him otherwise) ... to do detection and compile, change the file /usr/src/aureal-1.x/Makefile from this:

# Detect the chip on the soundcard
#ifneq ($(shell $(LSPCI) -d '12eb:3'),)
NAME = au8810
#endif
#ifneq ($(shell $(LSPCI) -d '12eb:1'),)
#NAME = au8820
#endif
#ifneq ($(shell $(LSPCI) -d '12eb:2'),)
#NAME = au8830
#endif


to this

# Detect the chip on the soundcard
ifneq ($(shell $(LSPCI) -d '12eb:3'),)
NAME = au8810
endif
ifneq ($(shell $(LSPCI) -d '12eb:1'),)
NAME = au8820
endif
ifneq ($(shell $(LSPCI) -d '12eb:2'),)
NAME = au8830
endif


Save the file and run the command (from within /usr/src/aureal-1.x as root):

make clean

make

make install
hkufahl
Done. Everything seemed to install. No errors.

Now what do I need to do?

Your patience with me is really appreciated!!!
hughesjr
Which card did it detect ... au8810, au8820, au8830? (I will assume au8810 for the rest of the instructions, if your module was different, substitute it for au8810)

You should be able to load the drive that was installed with the command:

modprobe soundcore
modprobe au8810




If that works, you should have sound....but to make it work when you boot ...

edit the file /etc/modules

and add the lines:

soundcore
au8810
hkufahl
Tried modprobe soundcard in /aureal-1.x and in root and returned error

modprobe: can't locate module soundcard

Thanks again!
hughesjr
nope ..... it will be:
modprobe soundcore
(not soundcard)

then

modprobe au8810

or

modprobe au8820

or

modprobe au8830

whichever was built as a module when you did the make command....
hkufahl
Sweet music to my ears!!! I now have a working sound card!

Thanks again! Your patience with a newbie has been unbelievable. I have learned alot, with alot more to learn, but I now have at least a small amount of confidence.

I did get one error message at startup, but the sound worked anyway.

error - artsmessage
sound server fatal error:
AudioSubSystem::handleIO:write failed
len=-1.can_write=4096,errno=11
(Resource temporarily unavailable)
This might be sound hardware/driver specific problem (See aRts FAQ)

Is this anything to worry about?

Thanks again! biggrin.gif
hughesjr
I don't use aRts with KDE, you can turn it off in the KDE Control Center.

Open the KDE Control Center, click on the Sound & Multimedia tab. Then select the sub-tab ‘Sound System’. Lastly, un-check the check box called ‘Start aRts soundserver on KDE startup’.
hkufahl
Thanks again. Turned off aRts. no errors. biggrin.gif
hughesjr
Your welcome ... biggrin.gif

make sure MP3s and Audio CDs play OK....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.