Help - Search - Members - Calendar
Full Version: Linux Newb Needs Help :-)
Linuxhelp > Support > Technical Support
y0shi
Decided it was time to jump on the band wagon.
I installed redhat 9 tonight, and yadda yadda took for ever...
I got to the prompt where i have to choose my video card, and i obviously picked wrong. Now when i boot linux X starts up automatically but shows nothing on my screen. ( using a laptop :- )
i don't really wana go and install it all over again.

when the screen is just blank i do the ctrl+alt+backspace.... but then the cmd prompt never comes so i gotta hit it a few times to get it to stay. This already happened once and i just formated the partitions and re-installed and made the same mistake but after i was in X. the first time it happened during installation.

Using a Geforce FX 5650....
i clicked on Geforce FX (Generic)
when i probe it gives me a vesa... so obviously i now know my card isn't directly supported.
anywho i have the HD partitioned and i can always boot to windows ( like now ) so it's not a huge deal but there must be something i can do to reset the X display configs with out re-installing? and then can i get my video card to work ? :-


sorry for the long post. ph34r.gif
Robert83
Hi, the problem is with the videocard, since it's new.

You'll need to get the latest drivers for linux from www.nvidia.com!

Second you'll need to start you're linux in level 3. Wich means
when you start the system at the boot, where it waits 10 second, type linux INIT 3

then just start it up... insert the cd with the nvidia drivers [which you have downloaded as mentioned earlier]

isue a command like mount /dev/cdrom
cd cdrom
dir
./ [enter here the name of the nvidia driver package]

install, then goto /etc/X11/

edit XF86Config
and search for a line in SECTION "DEVICE" Dirver = "nv" or "svga" switch it to "nvidia"

and then goto section MODULE

and make sure only these entries are listed

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

This is it
then enter reboot

and start linux normaly

Sincerely
Robert B
y0shi
yer a total pimp. thank you for such an explicit answer. :-)
y0shi
Arg...

"cd cdrom" doesn't work blink.gif

the mount worked though. mad.gif

so i skipped ahead just to check..

when i cd into /etc/X11 i cannot do "edit XF86Config" unsure.gif

tells me edit is an unknown command.

I do ls -a and it's there


I have the package burned onto a CD. Sorry for being a total newb lol.
Robert83
the default mountpoint for the cdrom is

/mnt/cdrom

so cd /mnt/cdrom

second on one of the cd's there is a package begining with mc[blablabla]....install that package
rpm -ivh mc[the missing text here].rpm and then type MC [sorta norton commander] and with it
edit the file, this thing makes life easier

So do this again please. Good Luck smile.gif

Sincerely
Robert B
y0shi
*bows down to you*

word for word precision. Thanks a lot man. I appreciate it.
Although i fear i'll be back soon enough wink.gif
Robert83
you're welcome smile.gif

Sincerely
Robert B
y0shi
and kablamo i'm back with another question.... this is one of the non-emergancy type :-)

My wireless card is a Dell TrueMobile 1300 ( internal )

Through about 3 seconds of reasearch i found that there are two programs that may be able to make it work.

One you have to pay for, and one is for free from source forge.

anyone have any ideas as to which one i should try ? is there another solution ?

I also don't know how to use the programs, and have not been able to locate newbie style instructions.

*sigh* i was on irc at the age of 13 on the old netcom servers.... still a windows kiddie 7 years later sad.gif

But 'm trying to learn linux, i partitioned once years ago and instaled redhat 6. Decided i didn't know what i was doing and accidentaly deleted my lilo bootstrap ( haha ) had to re-install windows and have it format the harddrive.... after such a grave attempt i am still trying to learn. so i appreciate you bearing with me Rob. This stuff would have taken me a long time to figure out. Thanks to any future helpers also, i know what it's like to deal with people that have no real clue what they are doing blink.gif

-y0shi

www.dilclan.com for anyone who plays JKA via linux or otherwise biggrin.gif ....actually i think it's www.dilclan.com/index2.php at the moment... to be www.dilclan.com again soon. We are overhauling the site.
y0shi
So does anyone have any suggestions ? ( just making sure i didn't get overlooked )

I've now tried both methods and to no avail.
Robert83
Have you looked on the Broadcom site? A driver is there - Broadcom makes the chipset in the 1300.

http://www.broadcom.com/drivers/?driver=44...x&cookiecheck=1

[make sure you browse it with a flash enabled browser] they have Linux drivers, you should give it a try,
personaly I don't have such a wireless card, [I use Linksys Bridge Units(External Stuff)]].

In the Dell forum it says that this is the stuff for the 1300, so I gues it should work


Sincerely
Robert B


ps.:http://www.broadcom.com/drivers/downloaddrivers.php [only if above adress won't work, this is a link directly to downloads]
y0shi
once again you know exactly what your talking about, and once again i have an issue.

"Makefile:18: *** Linux kernel source tree not found. Stop."

Now i read all the readme's and everything, and it said for pre-reqs to using this you must have "Development Tools" and "Kernel Development".... to install the tools and knerel source tree.... i ddin't do that initially. but i went into add packages, added those 2 and pop'd in the cd.

are there more steps i need to take ?

i have the tar file from the www.broadcom.com site extracted in /home/y0shi

and it says i have to build the driver bcm4400.o as a loadable module for the running kernel

so i cd into /home/y0shi/bcm4400-3.0.7/src

"make"

thats where i get the error.

again prolly something stupid i'm missing.
Robert83
when you type in console

gcc

and then

cc


what does it return?
y0shi
both return "no input files"

sorry for the delay was up doing something.
Robert83
hmm...don't know, just wait for a while perhaps someone will know...
Robert83
I think the prorer way for a installation from source is


enter console
got to the driver directory [the 1300[blabla] wich you've downloaded]
1. type in console ./configure
2. type in console make
3. type in console make install
y0shi
thanks for your effort man.... i downloaded newer iso's... .updated linux... installed the source

then i used driverloader ( www.linuxant.com ) re-did the nvidia steps and then managed to get the wireless card to work. ( with hours and hours of effort lol )

but hey it's all working... for now >=)

-y0shi
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.