Help - Search - Members - Calendar
Full Version: Uninstalling Woes
Linuxhelp > Support > Technical Support
genshi
after messing with linux I am definitely not ready to make this my sole OS on this computer. Maybe later on..
Im trying to uninstall Mandrake 9.2
I booted up with a M$ bootdisk and tried to format C:.. It wouldnt take.
so i tried fdisk /mbr and that didnt seem to do anything.. So I took the mandrake installation cd and ran it to where it allows me to customize the partitions.. I set it for one fat32 partition and formatted it through the install and then rebooted before it installed mandrake again.. Still didnt work.. Win98 will not set up on my C:.. It says it cannot read it and fdisk will freeze up. = help !
Robert83
start up the computer with you're win or dos boot disk

and enter FDISK [only FDISK!!!]

now there is an option Delete bla-bla something [can't remember]

and chose there, DELETE NONDOS PARTITION!!!!

That should fix your problem


Sincerely
Robert B
ccrisham
if fdisk does not do the trick the try fdisk/mbr
that should repair the master boot record
Robert83
he installed linux,...thus fdisk wont repair anything with /mbr...since the partition is either ext2, or ext3

thus fdisk only....and then delete non dos partition.... since ext2, ext3 is nondos[windows] partition


Sincerely
Robert B
hughesjr
Actually doing fdisk /mbr will fix the mbr (so that it no longer tries to boot to lilo/grub) ... but it won't allow a windows boot disk to format a ext2/3 partition ...

So, the advice to boot to a Windows disc with the microsoft version of fdisk and to delete all non dos partitioins is good ... but some versions of microsoft fdisk can't delete linux partitons.

So better advise might be boot to the mandrake disc 1 ... press F1 and type linux rescue at the command prompt ...

Exit directly to the console and then use the command:

fdisk /dev/hda

use the command p to print the current partiton table, use the d to delete all the previous linux partitions ... if only linux partitions were installed, delete all the partitions, then use the w command to write the changes to disk.

reboot with your microsoft disk that contains fdisk and issue the command:

fdisk /mbr

Then install your micorsoft product via the normal method...
ccrisham
well i have not seen any messages saying if any thing worked. my guess it did. well just in case it did not this is what happened to me my freind put linux on my system and i could not get x to run so i had to go back to windows. well i thought that i could just reinstall windows and it would work well i did most of the install and it even deleted my linux partion for me but did not fix the mbr. well after 3 or 4 days i called my freind and asked him what was going on and he told me that fdisk /mbr should work and it did.

so try to install windows first and then do fdisk /mbr

a nother situation that i had was i was a helping the network admin at my high school and he installed some program that messed with the mbr and it messed up some of the computer. i was not in there for a few days and when i came back i asked him what was rong and he told me and all i did was get a boot floppy and reboot and put fdisk /mbr in it and they all worked.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.