Help - Search - Members - Calendar
Full Version: Alsa
Linuxhelp > Support > Technical Support
hammerstein02
I installed the alsa-drivers-0.5.12a and then went to install the Alsa-lib-0.5.10b but the lib files when typing ./configure tell me that..

checking for alsa-driver package... not found or wrong version
configure: error: Install alsa-driver v0.3.0pre5+ package first...

does that mean I missed out a stage? I do have sound working.. from the drivers but I need to configure it. I was told to install the libraries..

Thanks for any help
Corey
My suggestion:

I would grab the alsa cvs version which is explained on Alsa's download page . The shortened version:

QUOTE
cd <directory_to_store_sources>    (i would make /usr/src/alsa)
cvs -d ':pserver:anonymous@cvs.alsa-project.org:/cvsroot/alsa' login

Type empty password here... (Press 'Enter' only)

cvs -z3 -d ':pserver:anonymous@cvs.alsa-project.org:/cvsroot/alsa' co -P .

Once the cvs tree is checked out, you may update your tree with the latest changes by going to the directory you checked it out in and typing:

cvs -z3 -d ':pserver:anonymous@cvs.alsa-project.org:/cvsroot/alsa' update -P -d


This will download the cvs source. Now, you need to go to your modules page for instructions. Goto the Alsa sound card matrix here and find your manufacturer and card and click on the corresponding "Details" buton. This will give you a step by step on how to set up everything for your card. The sources you downloaded are outdated, the CVS should be best for it. Make sure you have the latest version of CVS as well smile.gif
Hemant
a few weeks ago don't have any sound on my comp(linux).and when tried to compile 0.10b lib with 0.12a driver i got the same error but
installing 0.10b driver and utils 0.10 with 0.10b lib solves the problem.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.