Help - Search - Members - Calendar
Full Version: Another Laptop Issue
Linuxhelp > Support > Technical Support
I have an older pentium laptop that I loaded Red Hat 7.3. It works fine and is much more appropriate install than the RH 9 that was on it before. However, I cannot configure a my wifi cardbus adapter. Network configuration does not show wireless as a network connection. Is there a way I can use a wireless card with RH 7.3

Thanks unsure.gif
You might be able to use the card with RH 7.3 ... what is the make and model of the card....

For starters, I would download and install the latest RH 7.3 kernel .. which is:

Pentium II / PRO or higher Kernel

Pentium or MMX (less than Pentium II/PRO) Kernel

You will probably also need the Kernel Source:
Kernel Source

install these with:

rpm -Uvh kernel-2.4.20-28.7.i686.rpm kernel-source-2.4.20-28.7.i386.rpm
(if you downloaded the i586 kernel {only if you have a regular pentium or pentium MMX that is not P2 or Pentium Pro} then substitute i586 for i686 in the above line)

You might also want to install all the other RH 7.3 security updates by downloading apt for RH7.3 (the top file here) ... install it via this command:

rpm -Uvh apt-0.5.5cnc5-fr0.rh73.2.i386.rpm

Next, you might want to edit the /etc/apt/sources.list and change the lines:

rpm redhat/7.3/i386 os updates freshrpms
rpm-src redhat/7.3/i386 os updates freshrpms

so that they don't have the freshrpms (and only contain the updates and os) ... but I would probably just leave it like it is ...

Then to update all your packages, do the command:

apt-get update
apt-get dist-upgrade

You should now have the latest patches and files for RH 7.3.
The 2.4.20-28.7 kernel should support most wireless cards ... and with everything upgraded, there is a better chance to get it working.
The card is a Dell true mobile 1150. It has worked flawlessly with Redhat 9.
Tried the above but got a failed dependencies message.
modutils >=2.4.18 is needed by kernel-2.4.20-28.7 and gcc is needed by kernel-source-2,4,20-28.7
You will have dependancy problems (so after you get your NIC working, install apt)... in the meantime, all the updates you need can be downloaded individually from here:

You will have to pick the individual packages from within the i386, i686, and noarch directories. Once you are connected, you can just use apt-get to stay updated.
I have downloaded the kernel and attempted to install, but rpm comes back with modutils >=2.4.18 is needed by kernel-2.4.20-28-7

Any ideas on how to fix this one short of getting a new laptop? blink.gif
Go to the link I gave you in my last post (here it is agian ... it is all the updated packages for RH 7.3 since it's release)... go to the i386 directory and download modutils-2.4.18-3.7x.i386.rpm ... and gcc-2.96-113.i386.rpm ... (both your dependancy problem packages).

Put all the rpms you downloaded into a directory by themselves (should have only the rpms you downloaded ... including kernel, kernel-source, gcc, modutils).

install all the rpms with the command:

rpm -Uvh *.rpm

if you get any other dependancy issues when installing ... go to either the i386, i686, or noarch directories in the above link and downlaod the required package.
This still may not get the wireless card working, but newer kernels have support for newer items ... (which is why the card worked in redhat 9).
If this does make the network card work, you need to download the latest version of apt (for RedHat 7.3) from here (download the top progam).

Install it with the command:

rpm -Uvh apt-0.5.5cnc5-fr0.rh73.2.i386.rpm

Then use this command to update your apt index:

apt-get update

then this command to get all the latest security and bug fixes for RedHat 7.3:

apt-get dist-upgrade

Then every couple weeks you can download updates with:

apt-get update
apt-get dist-upgrade
Thanks, I think that will help. I also found that gcc was not loaded when I first installed RH. With gcc now on board, things should work better.

I appreciate the help smile.gif
Found another bit of information. Seems RH 7.3 shipped without wireless configuration installed. It was added later as an errata. I'm not sure which one, but at least this partially explains some of the difficulty.
I stalled the new kernel and modutils and that went well. installing apt and following the directions I was able to update a bunch of stuff that would have been impossible with out apt. Appreciate the help. Unfortunately, wireless does not come up as an option even now with 25megs of updates!! I must have missed something in here. Is there some other switch that needs to be turned on to get it going?
Hi you can try this :

-------------------------------------------------------------------------------------------------finegan Okay... this thread is now at 3, maybe 4 questions if the other guy ever gets back to us. Wiggidy weird:


I spent some time yesterday poking around trying to find more information on that TI 1410 under Linux. I couldn't find much as its rare, which is annoying as I'd LOVE to have one of those things! That one page suggested that it won't work properly under yenta. i82365 isn't resident on your system as Mandrake switched up to in-kernel pcmcia from the seperate package around then. The solutions aren't pretty:

-Switching to a distro that is still using pcmcia-cs and is recent (a combination of being in the stone ages yet modern). The only one I can think of is Slackware 8.1, but that's because that's all I really use. RedHat I know is no-go, SuSe too.

- Re-compiling the kernel, ground up, and taking PCMCIA out of its configuration, then re-compiling pcmcia-cs so its doing the job.

- Something I haven't thought of. All of the information I have on how to handle that controller comes from 1 webpage I found. Maybe you can try and have better luck. I know the issue has nothing to do with the wireless card, and everything to do with pcmcia being wonky. Maybe it will work with yenta, you can change your file back and see if you can pass yenta some of those options.


If this is just another Prism2/orinoco card, it should work off of the orinoco_pci module, not the orinoco_cs module as its not connected to a pcmcia bridge or bus of any kind. If you are indeed using Mandrake 8.1, you don't have the drivers for it, and worse yet, you can't compile the newer drivers against a kernel older that 2.4.10. What kernel are you running, this will tell you:

uname -r

Hopefully I just can't keep release versions and kernel versions in my head straight, but I think Mandy 8.1 released on 2.4.9. Regardless, you can download the drivers from]here, unpack them with, make them, and install them, and then configure the card with:

tar xvzf orinoco-whatever-version-you-get-I-recommend-.13
cd orinoco-blah-blah-blah
make install
modprobe hermes
modprobe orinoco
modprobe orinoco_pci (the one your distro doesn't come with)
ifconfig ethX up (X for whichever card it is, dmesg will tell you)
iwconfig ethX essid nameofsomethingnetworkish
iwconfig ethX enc someencryptionkey (if your wireless router runs encryption)
dhcpcd ethx (if your router is running a dhcp server... this step might kack anyway as some cards have a hard time grabbing a lease, post back and we'll sort it.)


Robert B
The question remains the same. How does one use wireless networking on Red Hat 7.3 on a laptop. Answering that question raised others brought about by ignorance of the linux operating system. Those answered, the problem remains. To answer your questions, the kernel is 2.4.18-3. The card is a Dell truemobile 1150 76 bit card. It is an orinoco chipset
Well, the problem is fixed. I know wifi cardbus adapter running on Redhat 7.3 just like it ought! It was fixed by installing redhat 7.2 as "Workstation." 7.2 recognized the card and configured it. On a lark I ran RH 7.3 as an upgrade and low and behold, my card worked just fine. Network configuration sees the card as a wavlan cs. I have a suspicion that red hat 7.x configured wireless connections, but only for workstations and not laptops. According to the release notes, the only difference is the lack of pcmcia services for a workstation.

After installing RH7.2 as a workstation however, my pcmcia still worked. So I am confused, go figure.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.