Help - Search - Members - Calendar
Full Version: Please Help! Can't Boot-may Have Lost Data
Linuxhelp > Support > Technical Support
TrevorNC
I am running RedHat 9.0 2.4.20-8 and my last shutdown (that I was able to perform) failed. Since that time, when I try to start up linux I get messages such as:

Enabling local file system quotas:
...... rc.sysinit /var/run/utmp no such file or directory

This message is repeated for several other files too.

I tried 'linux rescue' mode and mounted the drive that has all my data. The thing that is scaring me is that the directory that had all my data is empty.

I have pretty much figured out that my filesystem is messed up and I am pretty certain that the data is still there. Unfortunately I have no idea what to do next.

Any ideas and suggestions would be appreciated.

Regards,
Trevor
hughesjr
I normally recommend booting to the rescue CD and running:

fsck /dev/hdxx

(substitute your partition in question for xx)

Make sure the partitions you run fsck on are NOT mounted....
TrevorNC
Good news !! I am adding this update from my linux system.

I started up linux in rescue mode as you suggested, however when I tried to run fsck /dev/hda7 I was informed that it was already mounted. As I did not mount it, I did not know how to unmount it.

I tried chroot /mnt/sysimage to see if that would help (but it didn't).

What I ended up doing was running shutdown -r -F now. This actually failed, and I guess this is an effect of being in rescue mode, however it was sufficient to set the (-F) force file system check on restart.

When I next started my system the file system was checked and I guess repaired as everything seems fine now.

Guess who is going to back up their data tomorrow wink.gif

I wonder if there is a way to force a filesystem check on start up by modifying the parameters in grub.

Thanks for your prompt response.

Trevor
michaelk
FYI:
Rescue mode will mount /(root) to /mnt/sysimage as you have discovered. To unmount use the umount command
umount /dev/hda7. See man pages for mount / umount for additional help.

Normally a fsck will automatically be performed at start up after a set number of boots or after a certain period of time.
You can change the parameters using the tune2fs utility.

The fstab entry determines if the filesystem is configured for fsck at boot. See man pages fstab
hughesjr
And for the unmount ... if you also have a seperate boot partition, you would have to unmount it first (before trying to unmount the / partition)...since the boot partition is mounted in to the / partition

so it would be:

umount /mnt/sysimage/boot
umount /mnt/sysimage

(or you could just use the devices for /boot and / partitions)

umount /dev/hda2
umount /dev/hda7
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.