Help - Search - Members - Calendar
Full Version: Wierd Graphical Error
Linuxhelp > Support > Technical Support
avitarx
My computer has a few problems that seem to be related to the graphics card. These problems are on 100% of the time in Linux and I have not expierienced them at all in windows (I only spent 20 minutes on Windows trying to recreate them).

The first problem I started having was that my terminal display was wacky (about 6 months ago). When I typed "ls" the directores were displayed in blue (as they should be) but they had a strikethrough line in them. I could live that and was like oh well. Especially since xterm worked fine. next came the number 6 and the ^ symbol having a vertical line though them no matter what the context (typed ot displayed). After that all console display became unreadable (huge horizontal line through the screen). I was able to fix this by loading the frame buffer module. But still I had problems this the cursor. It would display a flashing ] instead of an underscore. Another problem I am having is that with the Nvidia driver loaded my computer locks up hard if I quite or restart X or shutdown. Or alt+fkey to a console.

Today when I booted my computer I had the added problem of random colors turning to pinky purple and text looking like terriblke antialiasing on an LCD (chunks missing and prismatic colors when it should be black). These problems do not show up when I boot into windows so I was curious if this was a hardware problem or a software one or both.

I am leaning towards hardware since things got worse when I did nothing and stayed the same with drastic software changes (kernel upgrade, same wierd artifacts with or without NVIDIA driver installed.
shaggy999
You haven't been feeding your computer mushrooms, have you? tongue.gif

Well anyways... um... about your problem... blink.gif I'm a n00b. Sorry. unsure.gif
hughesjr
I had similar problems, but it was the entire screen that was hosed, not just individual letters.

I had to use a different framebuffer mode ...

vga=788 and vga=normal in my grub.conf caused problems ... vga=789, vga=791, vga=792 all worked fine.

I also had major problems in Debian SID if I loaded the discover script at startup and used the nvidia drivers from nvidia.com.
avitarx
I will try the other vidio modes.

I am not home so I can't check what I have (I think 0x070f or 0f07) but 788 was definatly a big problem, (as unusable as no frame buffer).

Anyway, my question is what are the discover scripts?

I am using a half broken Mandrake 9.2 distro (not the entirerity of my problem but possibly part of it. The problem started with my fully working 9.0 though). All of my contrib sources return some error (I forget wht it is) when I update so it was not able to fully upgrade everything.
hughesjr
The discover script is debian's hardware detect script ... I still have to disable it to use framebuffer console modes
-------------------------------
I also get an error for the contrib (or disk_2) urpmi sources for Mandrake 9.2....it is:

medium "contrib" uses an invalid list file:
mirror is probably not up-to-date, trying to use alternate method


The mandrake forums say that the error is not relevant ... and my updates have been working OK (I just updated my Mandrake 9.2 install a couple minutes ago with no problems).

On my mandrake 9.2 install (with an 64mb NVidia Geforce2 400 MX) and a 2.4.22-26mdk kernel, I had vga=normal in the top of the lilo.conf and vga=789 in the kernel section (for the 2.4.22 kernel) of lilo.conf. When I started messing with the 2.6.1 kernel in Mandrake, that is when I started getting console problems and had to start messing with changing the vga= settings ... now I have vga=792 in both the top and kernel sections of lilo.conf and I have no boot problems with either the 2.4.22 or 2.6.1 kernels
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.