Help - Search - Members - Calendar
Full Version: Problem Mounting Hdd
Linuxhelp > Support > Technical Support
·Running Debian 3.0 r2 (Woody)

·Linux newbie !

·Cannot mount my second fixed hard disk !

·Have 2 fixed EIDE drives:

/dev/hda 6GB
/dev/hdc 4 GB

·Here is my /etc/fstab:

<file system><mount point> <type> <option> <dump><pass>

/dev/hda1 / ext2 error=remount-ro 0 1
/dev/hda5 none swap sw 0 0
/dev/hdc1 /hdc ext2 user,auto 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy auto user,noauto 0 0
/dev/cdrom /cdrom Iso9660 ro,user,noauto 0 0

·I have added the /dev/hdc1 description myself to /etc/fstab !

·Seems to be some discrepancy between the way the disk is described by fdisk and cfdisk !

·Device /dev/hda looks like this from fdisk:

Device Boot Start End Blocks Id System
/dev/hda1* 1 609 4891761 83 Linux
/dev/hda2 610 791 1461915 5 Extended
/dev/hda5 610 791 1461915+ 82 Linux swap

·Device /dev/hda looks like this from cfdisk:

Name Flags Part Type FS Type [Label] Size (MB)
hda1 Boot Primary Linux ext2 5009.20
hda5 Logical Linux swap 1497.01

·Debian install automatically made the primary partition type Linux ext2 and suggested a swap partition.

·I know partitioning is probably not ideal but have more HD than RAM so can be extravagant with swap partition !

·Unclear why simple cfdisk primary partition appears in fdisk as a combination of /dev/hda1 Linux (83) and /dev/hda2 Extended (5) which is invisible in /etc/fstab !

·Device /dev/hdc looks like this from fdisk:

Device Boot Start End Blocks Id System
/dev/hdc1 1 523 4200966 83 Linux

·Device /dev/hdc looks like this from cfdisk:

Name Flags Part Type FS Type [Label] Size (MB)
hdc1 Primary Linux 4301.83

·Cannot type this partition as Linux ext2 for love nor money. Well I can with the fdisk option "t change a partition's system id" but it isn't recognised by cfdisk !

·Tried using fdisk to mimic /dev/hda and create a Linux (83) partition and an Extended (5) partition, but cfdisk still shows it as type Linux (83) !

·Here is my /proc/filesystems:

nodev proc
nodev nfs
nodev devpts

·I try to mount my second hard disk with the following command:

mount /dev/hdc1

·This leads to the error:

mount: wrong fs type, bad option, bad superblock on /dev/hdc1, or too many mounted file systems

·I have tried several variations particularly using the -t switch with the type ext2. I have also tried specifying different file system types described by man mount such as ext but this doesn't figure in /proc/filesystems and is not supported by kernel ! I can only mount using -t proc or -t devpts which I know don't mount my device but tried out of desperation to see if I was using the mount -t switch correctly ! I also tried removing the options from /dev/fstab in case these were the problem but no success.

·I would LOVE to be able to mount and use /dev/hdc can anyone please tell me where I am going wrong !

Thanks in advance...

<Alex 7>
Do you have a directory called /hdc ...

To mount a drive, you must create a directory to mount into, so try:

mkdir /hdc

then try the mount command
Thank you for reply.

Yes I Do have a directory called /hdc which I created and have also tried the mount command specifying this as the mounting point !

I had thought the mount command didn't need to be given the specifc file system type and when I mount like this:

mount /dev/hdc1 /hdc

I get prompted to specify the filesystem type. If I do with the -t option like this

mount -t ext2 /dev/hdc1 /hdc

then I get the same old problem "wrong fs type, bad option, bad superblock on /dev/hdc1, or too many mounted file systems" !?
After you created the partition with cfdisk and/or fdisk did you create a file system on it?

The command to create an ext2 file system is:

mke2fs /dev/hdc1

This option is like formating a partiton in Windows ...
Thank you !

I'm embarrassed to say that that swung it ! I had assumed that cfdisk and fdisk did this process when I wrote the partition table to disk because I don't remember mke2fs or similar process running when I configured /dev/hda under the Debian install !

Had a feeling it would be something simple (user error !!!) !

Thanks again for your help and thanks to providers of this forum !!!

(PS. Still unclear why /dev/hdc must be typed Linux (83) and cannot be typed Linux extended (85) but not a serious issue !)

<Alex 7>
The mke2fs process was done by the installer on the original install...
I'm not sure why your swap partition is in an extended partition .... Let me try to explain what an extended partition is:

There are 3 types of partitions ... primary, extended, and logical. There can be only 4 primary partitions on a hard drive. The limitation of four is one that is imposed on the system by the way that the master boot record is structured.

If you want more than 4 partitions on a hard drive, you must create an extended partition (logical partitions are then placed inside the extended partition) .... So you would do this:

Create partitions 1, 2, and 3 normally (partition 1 at the beginning of the drive, 2 at the end of 1, 3 at the end of 2, etc.)(they are primary partitions) ... then create an extended partition (partition 4) that is from the end of partition 3 to the end of the drive ... then create partition 5 (inside the extended partition) starting at the beginning of the extended partition ... and partition 6 at the end of partition 5, etc. Partitions created inside the extended partitions (in this case partitions 5 and 6)are logical partitions.

Windows (and some other OSes like FreeBSD) need to have their boot partitions as a primary partition. Other OSes like BeOS and most Linuxes can boot from Primary or Logical partitions (some tools and installs for some linux distros won't install into logical partitions, but the OS will boot there after it is installed).

Here is what one of my multiple OS test machines looks like (hda, hdb and hdd):
Disk /dev/hda: 60.0 GB, 60022480896 bytes
255 heads, 63 sectors/track, 7297 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        13    104391   83  Linux
/dev/hda2            14      1580  12586927+  83  Linux
/dev/hda3          1581      1711   1052257+  82  Linux swap
/dev/hda4          1712      7297  44869545    5  Extended
/dev/hda5          1843      3148  10490445   83  Linux
/dev/hda6          3149      4486  10747453+  83  Linux
/dev/hda7          4487      5900  11357923+  83  Linux
/dev/hda8          5901      7297  11221371   eb  BeOS fs
Disk /dev/hdb: 60.0 GB, 60022480896 bytes
16 heads, 63 sectors/track, 116301 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

  Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             1     29065  14648728+  83  Linux
/dev/hdb2         29066     48442   9766008   83  Linux
/dev/hdb3   *     48443     67815   9763519+  a5  FreeBSD
/dev/hdb4         67820    116301  24434928    5  Extended
/dev/hdb5   *     67820     91071  11718976+  83  Linux
/dev/hdb6   *     91072    116301  12715888+  83  Linux
Disk /dev/hdd: 15.0 GB, 15020457984 bytes
255 heads, 63 sectors/track, 1826 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot    Start       End    Blocks   Id  System
/dev/hdd1   *         1         5     40162   83  Linux
/dev/hdd2             6        38    265072+  82  Linux swap
/dev/hdd3            39      1826  14362110   83  Linux

As you can see ... in hda and hdb, partition 4 on each is everything on the drive that is after partition 3 ... and all partitions on the drive above 4 are inside the extended partition.
I would recommend that you convert your primary and new partition to ext3 instead of using ext2 ...

ext2 doesn't handle improper shutdowns very well, and easily becomes corrupted on loss of power (or being powered off while running).

See this link.

If you didn't install the bf24 kernel for debian (type bf24 and hit enter on the debian install boot prompt), and/or if this is a new install with nothing very important on it yet, I would recommend that you just do a reinstall of debian (it's good practice anyway...) and pick ext3 as the root partition file system.

You have to use the bf24 kernel for debian to use ext3 (or reiserfs) ... see this link
Thanks for advice...

Yes will try re-install - done a few already but getting used to it by now!!! - and load bf24 kernel. Unfortunately, my BIOS don't allow boot from CD (flashed them once to make them Y2K (!) don't want to risk it again) so I have to run a batch file on the CD (/install/boot.bat) to kick off. This didn't give me any options as it should have but looking at it now I can force the bf24 option !

Will give it a whirl !

<Alex 7>

Went looking for bf24 kernel on my Woddy CD only to find that I can't install it because I get an error:

... invalid compressed format (err=2)

All other flavours kick off OK !

I seem to have traced this to a loadlin error (#142421) which is actually mentioned in the documentation !

No great problem. Have a "toy" system at the moment to learn about Debian Linux but if anyone knows if a fix exists would be grateful for info. Alreay have Vanilla flavour installed. Perhaps I can boot this and run a Linux loadlin (or similar) ?

<Alex 7>
Try doing the install from the CD-5 instead of the CD-1 .... (that CD is the BF24 CD)
Thanks.. was aware of Debian's "Woody" CD-5 (Binary-5) but assumed I would have the same problem. In the end I have managed to install the bf2.4 flavour from "Woody" CD-1 i.e. Binary-1 by booting into Linux by way of a rescue disk !

Just for the record, in case it helps anyone else, my main problem is that I have an old Pentium that doesn't offer boot from CD on its BIOS ! Originally, to install from CD I booted into DOS from a floppy that loaded CD drivers then from the CD itself ran /install/boot.bat ! All well and good for most flavours but when trying to load bf2.4, to make use of EXT3/ReiserFS, I bumped into the loadlin error (#142421) mentioned above. Essentially booting from DOS was preventing me from loading the bf2.4 flavour from Woody CD-1 !

Went away and burnt CD-5 as suggested. To run install on CD-5 required boot into Linux. To do this I had to cut a bf2.4 recovery diskette from rescue.bin and a second diskette from bf2.4 version of root.bin using RaWrite3.exe. Started system with rescue diskette and at the boot: prompt I typed floppy0 to kick off the installation process from floppy disk. Then I was prompted to install the root floppy disk and was dropped into opening bf2.4 install menu ! Subsequent screens allow you to choose the installation media so I opted for CDROM, obviously, but the automated search for a runable object kept producing an erroneous path and refused to install. There is no way to intervene to correct the path. In desperation I introduced CD-1 and low and behold the installation process chugged on to completion quite happily !

No doubt somebody will tell me what I could have done to use Disk-5 but, hey, I got there in the end ! Now have ReiserFS installed and am reading up !!!

Thanks again for help and advice… a very useful forum !
As long as it worked, that is OK ...

The purpose for the other iso's (that is all the Debian ISOs other than CD-1) is that CD-1 has multiple boot options (using a boot technique called isolinux) that is not compatable with all CD's ... so they created seperate boot disks so more people could boot from CD ...

Once you get the CD operating and the hardware detected (that is advantage of BF24 ... it boots the 2.4 kernel, which has reiserFS and ext3 support ... as well as many other 2.4 kernel hardware supported) then you install CD-1 to get the programs. When you created the BF24 boot floppies, you kicked off that 2.4 process ... which is the right way to do it if your PC can't boot from CD!
You better keep a good rescue floppy around! (In case you need to boot linux for rescue mode ... I just boot from either the CD-1 for the distro in linux rescue mode or use SystemRescueCd ... neither of which will work for you....UNLESS you get SmartBootManager (SBM) to work.

Give SmartBootManager a try ... download the latest version and make a boot floppy ... if it works, and allows you to boot from the CDROM, you can either keep the SBM boot floppy handy, or you can add SBM as your MBR ... meaning you could do future boots from CD without any problems.

That would add an extra step to your normal boot process thoguh, so the best solution might be to just create a SBM boot floppy and keep it where you can use it when you want to boot from it.
BTW, I was introducted to SBM because it is on the debian CD in images and I needed to boot a CD from a machine that coldn't boot CDs (not quite sure why I am remembering this now ... since you are finished smile.gif ) ... and you can write that version to a floppy with rawrite from dos (or dd from linux). In debian, go to the CD and it should be in the same place as the other boot floppy images, then do this:

dd if=sbm.bin of=/dev/fd0

(though it is a little older version ... the SBM website has new versions)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.