Help - Search - Members - Calendar
Full Version: Error Starting Dhcp Server
Linuxhelp > Support > Technical Support
chapmanb
I get this error "../etc/dhcpd.conf line 19: semicolon expected
range
^ "

Looking at line 19 I have a Semi colon there. Here is what I have in my Dhcpd.conf file:

subnet 192.168.1.0 netmask 255.255.255.0 {
option routers ;
range 192.168.1.10 192.168.1.20;
}

I excluded the default setings prior in this script file.

I used yast2 to do this and it gave me an error so I tried editing this file with vi but same error when I start it with rcdhcpd start

I'm probably have something stupid done that I don't know about. This is my first Linux box, so I want to set up a dhcp server at home and run samba server on it. I'd like to try connecting my XP box and log in to a domain, but I'm stuck on this first error.
I know I could use a static IP but that's too easy.

Any help greatly appreciated!
chapmanb
Hi all,
I managed to figure out what my problem was, I had a line option router ;
I just deleted it because I dont have a router in this setup.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.