Help - Search - Members - Calendar
Full Version: Rpm Trouble
Linuxhelp > Support > Technical Support
naza
Hello am new to this board but have been using linux for a while but am still a "beginner"

anyway, i seem to have developed a problem with rpm

Whenever i run anything with rpm i get the following:

rpmdb: fatal region error detected; run recovery
error: db4 error(-30981) from dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 - (-30982)
error: cannot open Packages database in /var/lib/rpm

Am running Mandrake 9.0

Any ideas?

Have searched these forums foir similar woes hand found a reference to "rpm -rebuilddb" but get same arror when i run this.

Any advice greatly appreciated

Thank you in advance


Naza
Jim
Are you trying to run these rpms from the terminal or from the graphical windows? If you are running it from the terminal what prefixes are you using? ie rpm -??? package.rpm?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.