Help - Search - Members - Calendar
Full Version: No Sound After 2.6 Compile
Linuxhelp > Support > Technical Support
yoh
Hi everyone. Here's my situation. I recently installed Fedora Core 1 with no problems and thought I would compile the official 2.6.1 kernel (from kernel.org). Compilation went ok with no serious errors but when I rebooted to test it, no sound. I have a SoundBlaster Live! card so i did a 'dmesg | grep emu10k1' with no results. When I was configing the kernel, I selected "sound card support" and subsequently selected OSS as the sound system and my card from the list. I've recompiled several times with different options (selected as intelligently as I could). Tried ALSA rather than OSS...same result. The really irritating thing is that whatever happened seems to have changed something that's kernel independent because the stock kernel that came on the fedora cd dosen't support sound anymore either. Sound worked fine before I did the 2.6.1 compile. If i do a 'dmesg' in 2.6.1, i get several errors that appear to be related to the sound. I dont know if the first one is though.


PCI: IRQ 0 for device 0000:00:1f.1 doesn't match PIRQ mask - try pci=usepirqmask
request_module: failed /sbin/modprobe -- sound-service-0-3. error = 256
request_module: failed /sbin/modprobe -- sound-slot-0. error = 256

The weird thing is that if I run Soundcard Detection under the System settings menu in Gnome, it sees the card, but when I push the test button, I get "The emu10k1 driver could not be loaded. This soundcard may not be compatible with Red Hat Linux."
If i use /sbin/sndconfig, i get the following

"You don't seem to be running a kernel with modular sound
enabled. (soundcore.o was not found in the module search path).
To use sndconfig, you must be running a kernel with modular
sound, such as the kernel shipped with Red Hat Linux or a 2.2
or greater kernel."

That's 2.6.1


In 2.4.22-1.2149.nptl, "dmesg | grep emu10k1" yields

"emu10k1: EMU10K1 rev 8 model 0x8064 found, IO at 0xd480-0xd49f, IRQ 5
emu10k1: SBLive! 5.1 card detected"

checking output of 'dmesg' dosen't appear to show any sound errors at all

the Soundcard Detection in the System Settings menu dosen't give any errors, but it dosen't give any sound either

/sbin/sndconfig detects the card fine but when i click on ok, it crashes saying it has a problem writing the config file.

the kicker is that i didn't touch the 2.4.22-1.2149.nptl kernel...it just failed after I compiled 2.6.1. Any ideas on how to get my sound back (even in 2.4.22-1.2149.nptl) would be great. If more info is needed, just ask. Thanks
hughesjr
I have (2) 2.6.x kernels compiles where the sound works with that sound card ... one is a Debian (based on 2.6.0 and using OSS) and one is a Mandrake (based on 2.6.2rc3, using ALSA). I didn't compile either of these kernels, they are part of the base install...but the sound works in each.

You can download and look at the config files for these kernels from here:

Debian 2.6.0

Mandrake 2.6.2rc3

untar them with tar -xvzf filename
yoh
Thanks. I'll have a look at them and see if I can spot my problem.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.