Help - Search - Members - Calendar
Full Version: Will Pay For Help
Linuxhelp > Support > Technical Support
I am having problems configuring my Linux/Apache server correctly.
Using SSH and Webmin to access server.

My problems are:

.cgi&.pl will not work in /home/www/*/cgi-bin
Openwebmail will not work in user areas.
oscommerce will not ssl, but ssl does work in webmin
oscommerce will not register guests

What do you think? Can anyone help me? How much do you want?
It all seems a easy fix, but I have been through it in and out.

Just email me. Please..
If you want to use SSL on a webserver, you need to generate (or obtain from someone like Verisign) an SSL certificate.
I have managed to use SSL on webmin. This does create a certificate although it is not considered valid to the world. So a warning pops up about it and I can accept( install) the certificate.

My major problems were around apache 2.0.48 version.
It seems mod_ssl 2.8.16 for Apache 1.3.29 is not suited to Apache2

So I spent some scary moments in installing 1.3.29 over Apache 2.0.48
last nite. I was successfull in doing that. And then other modules were added as per 'install' directions in oscommerce.
Using these:
tar -xzf openssl-0.9.6.tar.gz
tar -xzf mod_ssl-2.8.1-1.3.19.tar.gz
tar -xzf apache_1.3.19.tar.gz
tar -xzf php-4.0.4pl1.tar.gz

It worked fine. But I did have to reinstall perl and have been struggling with mod_perl.

I don't really know what mod_perl is but I believe it used to be module in my apache. I have followed mod_perl instructions many times. and I believe I had it once but lost mod_ssl & mod_so. I tried the flexible install but have not been able to get mod_perl back. But I do enable perl in the apache configure.

Good news I have apachessl. Going to https: asks about my cheesy certificate.

Bad news:
I have still the same problems.
.htaccess worked on 1 virtual site of oscommerce
.htaccess did not work on the other virtual site of oscommerce

since then I have disabled both
Now the one site directories I used to have password protection on now will not let me in at all.

What is there with this .htaccess stuff? It is like some sort of time delay on any changes or I am not changing something.

I have looked for months trying to energize my /home/www/*/cgi-bin
Maybe this has something to do with mod_perl?

Someone must need some extra bucks? Or maybe just a humanitarian effort to save my sanity.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.