Help - Search - Members - Calendar
Full Version: Trouble With Mouse On Mandrake 9.0
Linuxhelp > Support > Technical Support
Paulabc
Hi

I have AMD 2600+xp cpu on a asus a7n8x mother board with 256mb ram, a winfast leadtek 2000xp tv card ,a soudblaster live, a normal ps/2 wheel mouse ,a cd writer ,a dvd writer, nvidea geforce 4 mx440 seand of couse a hdd.

My problem is simple during installation my mouse worked perfectly but as soon as I boot up the first time the mouse cursor is stuck in the top left corner of the screen and it won't budge.
I can move the mouse and click on everything but it like shooting in the dark.Has anybody had this problem or have a solution to this problem.


regards
Paul
hughesjr
Yes ....

what does it say in your file:

/etc/X11/XF86Config-4

in the section Section "InputDevice" for your mouse ... my Mandrake file says:

CODE
Section "InputDevice"
   Identifier "Mouse1"
   Driver "mouse"
   Option "Protocol" "IMPS/2"
   Option "Device" "/dev/psaux"
   Option "ZAxisMapping" "4 5"
EndSection
Paulabc
I checked the settings in the x86config-4 file and it matches what your file says exactly, is there anything else that I can check or provide more information. And how if the x86config-4 file was wrong how do you edit it I tried gedit but when I tried to save it it prompted me with a the owner is root you do not have permission etc. etc. ??? I think or let's say I have a strong suspicion that it has something to do with display drivers. I can get 1280 x 1024 resolution 32 bit color on my windows xp installation but with linux I only manage 800 x 600 16 bit color. I selected the geforce 4 generic but it reverts to the geforce 2 ddr generic and when I do the test the mouse is already gone. I have found drivers for nvidia cards on linux from nvidia's site but I have to compile it. I try that and hopefully I will have happyness.
hughesjr
open a terminal window ...

type su - root

(login as root in that window ... do everything else from the root logged in window)

Issue the command:

xhost +
(allows a process started by root to show up on your current user's X desktop)

gedit
(This gedit is run as root ... you should be able to open and edit the file now).
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.