Help - Search - Members - Calendar
Full Version: Major Mandrake Problem
Linuxhelp > Support > Technical Support
Jim
So I am trying to install Mandrake on my friends computer, and after fighting his three hard drives for an entire night to move everything around and what not I finally got it on and working.

So than this morning he moved his secondary hard drive from the second IDE to the RAID and I had to re-install the boot loader. So I got it all installed and booted into windows. But now when you try to book linux it says

Code 80 38 00 8a 52 24 04 74 10 38 10 75 04 8b 40 04 c3 83 c0 88
<0> Kernel panic: Attempted to kill init!


You get that message no matter what you try to do. Load recovery, install RedHat, install Mandrake, what ever. So I formated over the linux partitions and tried to re-install. Same error message. I asume therefor that its an issue with the boot loader but since I can't get into rescue mode to re-install the boot loader what am I going to do? Any help? Please, I have tried everything I can, I swear I have put in like six man hours on this, nothing, I have rebooted this computer more times than the Spirit Rover. Help me.....
hughesjr
Can you boot from the Mandrake CD-1 and do linux rescue (or the RedHat CD-1)?

First rule ... make sure you have your drives the way you want them BEFORE you install.

Is he using RAID in RAID mode or just as a controller? Some of the motherboard RAIDs are software type RAID and not really RAID at all (kind of like a WinModem not being a full modem). It is best not to install Linux (or grub / LILO) on a drive connected to the RAID controller of those type of RAIDs.

If he is booting from the RAID partition in windows (as RAID drives), then the LILO (with MBR being on a RAID drive) might be confused ... your best bet would be to install Linux to boot to it's own partition only (and not to MBR) ... then use bootpart (here are some instructions on how to use boot part) to boot linux from a stand alone drive.
Jim
The drive with the OS's on them (both windows and linux) is on IDE0. The only drives we were moving around were IDE1 and the RAID one. Which like you were saing is a motherboard RAID. The RAID drive is only storage. The bootloader (LILO) and both OSs are on the Master IDE slot. (At least I am ninety percent sure that thats were the boot loader is. I will double check that and post again)

I can't get into safe mode from either my Mandrake or RedHat CDs it gives me the same error on both of them. I get the welcome, what do you want to do screen, and when I type Rescue it goes into the loading stuff and than craps out with that error code.

I am really at a loss, and he really doesn't want to have to reinstall windows. As far as I can tell the problem has to be with the boot loader because there is nothing "linux" left on the computer except lilo, I compleatly formated over the old linux partitions. So now what?
hughesjr
I've never had a problem where I couldn't boot:

linux rescue ...

You might try System Rescue CD (the latest version is 0.2.10). Once you get to the command prompt, make a directory so you can mount your root directory (I usually do mkdir root) ... then mount the linux root directory:

mount /dev/hda3 /mnt/root
(substitute the actual linux root directory)

If you have a seperate linux boot directory mount it as well ....

mount /dev/hda2 /mnt/root/boot
(substitute the actual linux root directory)

You can use fdisk -l /dev/hda to verify your partitions...

Once you have root and boot mounted, do a chroot (change root) to the linux partition and run lilo....

chroot /mnt/root /bin/bash

edit lilo.conf:
vi /etc/lilo.conf

save any changes and run lilo ...

/sbin/lilo -v -v

It should fix your lilo MBR.
Jim
Ok, so I finally got to try to fix my friends computer.

Ya, I tried to run the Linux Rescue CD, at the first prompt you get I just pressed enter. It goes through some stuff and than gives me that same error.

So what can I do? I am going to play with some of the other option on the CD, but I am sort of miffed.

I think my friends computer just got compleatly owned.

What now?
Jim
I just thought I would remind you that I formated over my linux partition. There is no linux filesystem left on the computer. The only think left is Lilo, and I don't even think thats there anymore, its at least not loading, its going straight to windows now. But I still get the error code no matter what I do.
hughesjr
So,

if you boot the linux SysRescue CD, it doesn't even make it through the boot process?

That is very wierd indeed. The SysRescue CD is totally standalone (it doesn't boot off the hard drives at all, and will even boot on a machine with a cdrom and no hard drives) ... you might try it with these options (type at the command prompt)

nofb noapic apic=off

It could be a problem with his CDROM .... or reading the PC's BIOS
(did you guys make BIOS option changes between when it worked and now)

Another possibility is this .... some hard drives have a Master setting, a Slave setting, and a Single (single means no other drive is on that channel) setting. Maybe one of the drives is now set for master, but it is on an IDE channel by itself (meaning it should be set for single) (or vice versa) ... so I would recommend checking the jumper settings of all the IDE devices and make sure they are all set correctly. Not all drives have a single setting.

(a conflict from the BIOS on the IDE channel could cause the channel to reset making the kernel on the CD unavailable during the boot process).

and you might consider using your CDROM drive in his PC to see if that is the problem.
Jim
Ok, so I opened up the computer, made sure the jumpers were all in the right place. I put the master on Master with slave present and the slave on Cable Select because there wasn't a slave option. Tried to install or rescue or do anything. Nothing worked.

So I tried some other jumper settings, still didn't work.

So I put a new piece of IDE cable in. Still didn't work.

So now I am writing in again. I think this computer might just be rejecting linux as a whole, but it took it before. I am totally miffed.

Jim

Oh ya, we didn't touch the bios when we were doing everything except to make it boot from floppy.
hughesjr
Try booting with the command:

linux nousb
Jim
There isn't a linux left to boot to. Its no longer a boot issue. Linux is gone, compleatly and totally gone, I formated over the drive. There is nothing left. Now its an install issue, it has been since almost the begining. After I tried a couple things and it didn't work I tried to re-install linux, when that didn't work I formated the partition. The only reason I was still trying to get into the rescue mode was because I wanted to re-install LILO because I thought that might be part of the problem. I get the error now when I try to install or when I try to go into rescue mode.
hughesjr
What I meant (but didn't say...sorry) was try the install (or sysrecue disk) with usb detection disabled.

so on mandrake (press F1 to get the prompt) or redhat CD-1 type the command:

linux nousb

or from the rescue CD press F2 then try :

fb800 nousb

-----------------
The error doesn't seem to have anything to do with the LILO install ... because booting from the CDROM in rescue doesn't look at the lilo install or try to mount the hard drive until much later in the process. Whatever is wrong that won't allow RedHat, Mandrake and the SysRescue boot disks to boot is somehow related to the kernel boot process from the CD's and not software currently installed on the CD.

Things that could affect all three boot CD's are:

A BIOS detection issue (Linux looks at the bios at the beginning of the boot process), A CDROM reader issue (A CDROM reader that is having problems reading the CD's), a Memory Issue (to test the Memory, use the command memtest from the SysRescue boot CD and let it run to check for memory errors).

On the SysRescue CD, what is the last printed line before you get the error? Do you get to the part where it displays several Countries and asks you to pick a key map?
Jim
I will get the last error line for you when I have a chance to work on his computer but I know for a fact that I don't get a country selection thing. I don't get any prompts at all.
Jim
ya, big suprise, that didn't work.

So the last few lines go something like this...

Stack: (whole bunch of numbers)
CallTrace: (another whole bunch of numbers)
Code: (same as in first post)
Kernel panic.....

I am still compleatly miffed. I gues it wasn't so much that I thought something was wrong with LILO as the boot sector of the hard drive because thats the only thing that may have changed since I got it to install the first time.
hughesjr
Very strange indeed....

What is the motherboard (and/or System if it's a dell or HP, etc.) model number? Maybe I can find something relevant on google...
Jim
Its a custom system, wich probably expains half of it, the mother board is a Soyo KT-400 Dragon Ulta Platinum edition. The bios is Phoenix-Award BIOS v6.00PG
Cwix
Its not an inherent problem with the motheboard, Ive installed a number fo different linux flavors on a computer with the same motherboard. I had redhat 8 and suse 8.2 pro both installed on that system and I never had a problem installing it.. hell the the motherboard seemed to love linux, the only thing linux didnt like on that system was the nvidia video card.
Jim
I know its not the mother board. It has to be an issue with the hard drives. I pulled the other two out and was able to get it to install on the Master. But as soon as I plugged the other two in it wont boot any more. I am going to play with it today some more and try to isolate if its the raid hard drive or the slave that is causing the conflict.

Jim
hughesjr
I have never installed one of those motherboards ... I normally use only Tyan boards if I build a generic system ... not because they are better or worse than any other company ... just simply because they had a board at a good price when I built my first generic system many years ago and it worked.

Good luck, This is indeed a very stange problem.

I think that you are definately on the right track ... either there is a master/slave setting issue with the BIOS and/or combination of drives being used that causes the linux problem ... OR ... there is a problem with having any RAID drives and installing Linux.
Jim
It is definitely the RIAD HD that is causeing the issue. When we unplug that hard-drive it will boot up fine. So is they a command that I can amend to the boot line that will make it ignore RAID or any advice on how to get it working. Since its a built into the mother board I am asuming that the drivers for the mother board would help. Does anybody know where I can get Soyo drivers?
Cwix
The soyo cd is back in georgia with my GF while im up here in Alaska, so its kinda hard for my to pull the driver off the cd for you. Soyo does have a windows XP driver on there web site.

You best bet I figure is to turn off raid in the bios by:
1: Soyo Combo Features menu
2: Scroll down to " Onboard IDE Raid"
3: Disable it and save settings

as an added bonus this will speed up your booting process... it will no longer look for drives on ide 3 or ide 4.....

BUT you will no longer be able to use thoes two ide channels.. so youll have to make room on the other two ide channels for that drive, or youll have to buy a bigger hard drive, and replace one of the drives on thoes two channels. Or you could buy a external usb drive, which surprisingly i havent had any complaints. its almost as fast as a internal drive, and linux recgonizes it (suse does neways)

Good Luck
hughesjr
Doing a search for the SY-KT400 board, I found numerous posts of this problem ... all the recommendations were to turn off RAID. Kind of silly to spend extra money for a RAID controller and turn it off....I found that the SY-KT400 uses the Highpoint HPT-372 RAID Controller.

I looked in the 2.4.20-28.9 RedHat config file and there is support for HPT-366, but not HPT-372 type devices (same for debian 2.4.24 kernel source). I think the problem is that the HPT-366 driver is causing the crash of the kernel when applied for the HPT-372 RAID controller. When specifically looking for RAID HPT-372 on Linux, I found what I think is the fix to your problem.... to pass in hde=noprobe hdf=noprobe hdg=noprobe hdh=noprobe on the kernel line (in grub) ... or ... append =" hde=noprobe hdf=noprobe hdg=noprobe hdh=noprobe" (in LILO).

If you actually want to use the RAID with Linux, then if you flash to the latest motherboard BIOS (from www.soyo.com.tw )... which will include the latest Highpoint HPT-372 RAID bios (make sure to use the correct sy-kt400 model ... there were 3 that I saw ... lite, ultra and premium on the soyo site).

Then you can go here for the latest Highpoint HPT-372 RAID drivers and install manual ... for RedHat and a bunch of others. Download and unzip the RedHat 8/9 drivers and look in the Docs directory for installation instructions on RH9 ... the pdf file also contains much info on how to use this RAID on Linux and how to load the drivers for both installation and for normal operations of the system.

I wouldn't use the RAID for both Windows and Linux partitions ... I would instead pick one or the other and use only that OS.
Jim
Thank you very much, I will probably give it a shot some time this week. The plan was always to have one NTFS partition on that drive. Its not even so important to be able to access that drive from linux, but I will screw around with it and see what happens.

Thanks a ton guys.
Jim
OK, so I have been really busy lately and this kids linux system as just kind of been sitting and collecting dust. So now I am going to try to go back at it.

I updated the bios, but I couldn't find highpoint drivers for Mandrake 9.2 and hints on where to look would be great.

Second I still haven't been able to get his network card(s) working. He has built-in one on the mother board and a generic PCI one. I have tried HardDrake about a hundred times with no success. I have ripped out the PCI one and tried to get just the built in one to work, but that didn't work. I have never patched the kernel for the chipset because i have been un-able to find linux drivers for the mother board. NVIDIA posted the ones for mine right on thier websight but Soyo doesn't seem to be as friendly to linux users.

Sorry to be digging back up such an old thread but I have been realy bussy. Any hints on where to get drivers would be great.
hughesjr
I can't see any rpm's specifically for mandrake ... looks like you will have to compile the source tarball...
Jim
Are you talking about doing the source tar ball for the HighPoint drivers? And if so, how would I go about doing it from a tarball?
hughesjr
Go here for info on how to make the board's NIC work.
hughesjr
Make sure you have the kernel-source for your current kernel and that /usr/src/linux is pointing to that kernel source directory.

To build the hpt drivers from the source, download this file ... put it in a directory by itself and change to that directory.

tar -xvzf hpt3xx-opensource-v131.tgz

Follow the directions in the readme.txt file...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.