Help - Search - Members - Calendar
Full Version: Mounting 2nd Harddisk Problems.
Linuxhelp > Support > Technical Support
the_fujiguy
Hello, I am a newbie so please be patient. I have recently decided to try Linux in a spare box that I have. I installed the Slackware version9.1 and seems to be working ok. My problem is I installed a second drive that had fat32 (vfat) data on it already and I want to access it under Linux. I added a directory for a mount point /home/tempdrive. Then I edited my fstab and added /dev/hdb1 /home/tempdrive vfat users,rw,auto 0 0.

The drive mounts fine and I can see access it while logged in as root but I cannot access it under KDE desktop 3.1 when logged in as another user (under the users group). The funny thing is if I start the gnome desktop under the same user the mount point is on the desktop and accessable.

I am not sure what it could be. Help is appreciated.

Thanks
michaelk
Welcome to linux.

For all users to read / write to a FAT32 partition you need to add the option
umask=000.

For info see man pages for mount or search the web.
the_fujiguy
Thanks, I actaully tried it but still nowhere. I also tried to chmod -R 777 the whole mount but it doesn't seem to change a thing. Just got to keep trying I guess and keep reading.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.