When I first installed SAMBA it was easy to configure it to share drives, and it worked super fast!!![really fast!]. But when it came to printing I had quiet some trouble, but then I've found a way that works 9/10 [reinstalled Red Hat a few times , just to see...].

-----------------------------------------------------------------------------------------------

So you install you're RED HAT 9 [I use custom mode, partition manually etc], don't install the RH9 SAMBA version, since there are some speed isues with it [atleast in my enviroment, win2000pro,win98se,win95,novell,xp home,xp pro]. Download Samba 3.0.1 and install it [but first make sure you delete smb.conf, since sometimes it makes some errors while installing delete the file /etc/samba/smb.conf.

First install you're printer in Linux, I've used KDE print server added the new printer give it a name,
I've used a Canon i550 for testing , so my printer name was i550 , and printer descripiton was Canon i550. !!!Share the printer by right clicking on it's name, and make sure that the printer is enabled to accept ques from all hosts [later you can edit this].

Now you should'v gotten a test page from CUPS if everyhting is ok, then be happy [by the way, I've used s500 drivers, since there are no i550 drivers].


!smb.conf should be as short as possible! <--it's checked by samba on a regular basis.

my smb.conf looks like this

[global]
workgroup = xxx
server string = yyy
printing = cups
printcap name = /etc/printcap <-- now this is the first problem [if u use cups , it won't work, dunno why? ]
load printers = Yes
log file = /var/log/samba/log.%m
max log size = 50
security = SHARE <--thus no passwords will be asked

[home]
comment = Home Directories
browseable = no
writable = Yes
valid users = %S
create mode = 0777
directory mode = 0777

[i550] <--use printer name here!!! [in my case the printer name is i550]
comment = Canon i550
path = /var/spool/samba <--make sure it's rwxrwxrwx nobody / nobody
printing = raw <--rather use windows own settings when printing
browseable = Yes <--see the printer in the network neighbourhood
printable = Yes
guest ok = Yes <--IMPORTANT , this allows anyone without an acount on Linux to print to it
use client driver = Yes [WIN2K,WINXP,or all of win, IF YOU GET ACCESS DENIED ERROR use this line]
print command = lpr -l -r -P%p %s [ALSO IMPORTANT]

[C]

bla-bla
this is only my shared driver, not important to you


So whit these settings you should be able to print, tested under RH9 a lot of times.


OTHER ERRORS

I was playing with it for a while.
I you turn of Linux not the way it's ment to be turned of, or power failure.
And next time when you boot up and cannot print, just delete the file
/var/lib/samba/printing/i550.tdb and restart the computer [note i550.tdb, is only called i550 because my printer is i550 if u use something else it will be called something else].

Hope this helps someone, because I finaly managed to get it working, and not just by accident smile.gif