Help - Search - Members - Calendar
Full Version: Apche Hassels
Linuxhelp > Support > Technical Support
cainbrain
Being new to linux I came across an apache guide http://linuxhelp.net/guides/apache on how to set up apache.
this is the conf. file

User www-apache
Group www-apache

ServerAdmin admin@192.168.0.x.com
ServerRoot /usr/local/apache

ErrorLog /usr/local/apache/logs/error.log
CustomLog /usr/loacal/apache/access.log combined
PidFile /var/run/apache.lock
ServerName www.192.168.0.x.com
MinSpareServers 5
MaxSpareServers 15
StartServers 9
ServerSignature On
DocumentRoot /usr/local/apache/htdocs
DirectoryIndex index.html index.shtml index.php index.cgi index.htm

AddHandler cgi-script .cgi
AddType text/html .shtml
AddHandler server-parsed .shtml
AddType application/x-httpd-php .phtml .php

NameVirtualHost 192.168.0.x
<VirtualHost 192.168.0.x>
ServerName www.<ip address>.com
DocumentRoot /usr/local/apache/html/linuxhelp-error.net
ErrorDocument 404 /404.php
ErrorLog /usr/local/apache/logs/linuxhelp-error.log
CustomLog /usr/local/apache/logs/access.log combined
ScriptAlias /cgi-bin/ /usr/local/apache/html/linuxhelp/cgi-bin/
<Directory> "/usr/local/apache/html/linuxhelp">
Options Follow SymLinks include Indexes
AllowOverride None
<Directory> "/usr/local/apache/html/linuxhelp/cgi-bin">
AllowOverride None
Options ExecCGI
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

When i try and connect to http://192.168.0.x im my web browser i get an error message
"The connection was refused when trying to connect to 192.168.0.x"

I have also tried searching google for the error but i havnt had any luck.
just wondering if some-one can pls tell me were i have gone wrong.

i have fadora core 1 if that helps

thx
hughesjr
Did you compile and install apache from source (as in the example) or use the RPM based install?

If you used the apache that comes with fedora, then you can't use the config file in our example...

at least not the:

user
group

and probably not any of the pathes

(unless you manually created them that way)
-----------------------------
Which type of install are you using ... a compiled install or the Default install included with Fedora Core?
chrisw
ServerName www.<ip address>.com


the line above is copied from your httpd.conf example
you posted.


its wrong

anywhere you have www.<ip address>.com

take off the "www" and the ".com"

and restart your webserver and see if you can connect
cainbrain
thx for your help, i managed to figure out that i never restarted my apache server after configuring it! ohmy.gif .

but now im batteling to set up the apache for windows.
what will my 'network domain' be?
is my 'sever name' my ip address

can anybody please just let me know if i am on the right lines
thx
chrisw
yes your server name would be your ip addres if you dont have a domain name...so where it says server name you would just put
the ip address of your server
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.