Help - Search - Members - Calendar
Full Version: Nic Problems And Redhat9
Linuxhelp > Support > Technical Support
arnjukajr
Ok, I have an old IBM machine that I installed Redhat 9 on. At first the network card and everything was working just fine. I had the machine off for about 2 weeks, and when I went to turn it back on, the network card wouldn't init during the boot process.

dmesg show's the following in regards to the NIC:
8139too Fast Ethernet driver 0.9.26
8139too: 00:0c.0: region #1 not an MMIO resource, aborting
Trying to free a nonexistent resource <00001200-000012ff>

Then it finishes booting, when I attempt to <ifconfig eth0> it gives the same output. Also the NIC is hooked up to a netgear router and the link lights on both the router and the NIC are lit up.

What happend here, anyone?

-jason
hughesjr
Did you add any cards to the machine or change any bios settings?

Looks like either one of 2 things ....

1. The settings for the card changed (ie, if it is set by the BIOS, the address changed).

or

2. There is more than one item assigned to that memory location.
arnjukajr
I did change some bios settings. I don't think it's that because I reset them back to default and it still doesn't work.

How can do I control the settings for the NIC card in linux. I'm not even sure what the commands are, or the config panels are for doing that.

-jason
hughesjr
In redhat 9, you can type the commands:

redhat-network-config

or

redhat-network-control

from a root terminal window

(They are also Menu - System Tools - Network Device Control for redhat-network-control and Menu - System Settings - Network for redhat-network-config.
arnjukajr
Hmmmmm.... These commands don't work. I have a BASIC install of Redhat9 without any gui installed.
hughesjr
If you have the program kudzu installed, you can remove the network information from the file /etc/sysconfig/hwconf and then run kudzu and setup your network card again (backup the file /etc/sysconfig/hwconf before you start, so you can put it back if something breaks).

This (there is other code above and below the <snip> tags ... I just wanted to show 3 devices from my hwconf file and remove the one in the middle) is how to remove the card:
CODE
<snip>
class: OTHER
bus: SCSI
detached: 0
device: sg1
driver: ignore
desc: "Esg-shv SCA HSBP M20"
host: 1
id: 6
channel: 0
lun: 0
generic: sg1
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: e1000
desc: "Intel Corp.|82546EB Gigabit Ethernet Controller (Copper)"
network.hwaddr: 00:07:E9:04:AD:1F
vendorId: 8086
deviceId: 1010
subVendorId: 8086
deviceId: 1010
subVendorId: 8086
subDeviceId: 3415
pciType: 1
pcibus:  3
pcidev:  7
pcifn:  1
-
class: SCSI
bus: PCI
detached: 0
driver: aic7xxx
desc: "Adaptec|AIC-7899P U160/m"
vendorId: 9005
deviceId: 00cf
subVendorId: 8086
subDeviceId: 3415
pciType: 1
pcibus:  4
pcidev:  7
pcifn:  1
-
<snip>

would become this:
CODE
<snip>
class: OTHER
bus: SCSI
detached: 0
device: sg1
driver: ignore
desc: "Esg-shv SCA HSBP M20"
host: 1
id: 6
channel: 0
lun: 0
generic: sg1
-
class: SCSI
bus: PCI
detached: 0
driver: aic7xxx
desc: "Adaptec|AIC-7899P U160/m"
vendorId: 9005
deviceId: 00cf
subVendorId: 8086
subDeviceId: 3415
pciType: 1
pcibus:  4
pcidev:  7
pcifn:  1
-
<snip>

Now save the hwconf file, then run the command kudzu ... kudzu should detect and then allow you to setup the network card.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.