Help - Search - Members - Calendar
Full Version: About Not Using Root Account?!
Linuxhelp > Support > Technical Support
nelson
could someone please help me out here?

Im new to linux, and am trieng to do things "by the book" not using the root account.
However when i try to run scripts with a normal user account as #su (and correct password) I get a #: bad interpreter: No such file or directory
error.

Iḿ sure there isnt a lot of magic needed to get around this problem, but i just havent figured it out! blink.gif

Thanks
gangsta_style
???? I don't get what you are asking. Can you rephrase that please?

But if you are trying to log in as root all you do is type "su" then the password. Not "#su"... I have never seen that before!
jetblackz
That means you wrote the file in Windows and ran it inLinux.
nelson
Ok, I will try to put the problem to you again.. having spent some more time investigating.

My objective is to update my ATI Radeon 9200 on my RH9 system.
I visited ATIs support site, the drivers they have for the display adapters are XFree??? specific. Meaning that I would have to know what version on XFree I am running at the moment. Being a newbee with linux OS I followed their advice and downloaded a script named Check.sk that suposedly would tell me what XFree server version I am running.

I did a chmod 777 on the Check.sk and then tried to execute it with ./Check.sk
: bad interpreter: No such file or directory

I then put the file i the /sbin and /bin directorys hoping it would run, but, again..
: bad interpreter: No such file or directory

I thought it might have something to do with being loged in as normal user and trieng to run it through the su command but I get the same error loged in as root!!
Script file starts off with #!/bin/bash and I use the default shell interpreter that installed with RH9.

unsure.gif

Hope this adds some logic to my last post, and sorry for not making sense eralier on!
hughesjr
Actually, the file is named Check.sh not Check.sk ... but assuming you typed in the right name to run the file ... htere can be several issues.

Did you open or edit the file with a windows text editor ... if so it may have ^m or ^p characters now at the end of the lines ... DOS/Windows adds CRLF (carriage return / line feeds) to the end of text files and Linux does not...try opening the test file with a Linux editor, like vi or gedit, and see if you se ^m or ^p at the end if the lines.

some things must be done as root ... and installing driver modules is one of them ... (can be done via a root terminal window). Usually any make install operation (or script that installs files) must be done as root.
-----------------
What happens if you type /bin/bash from the command line...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.