Help - Search - Members - Calendar
Full Version: *newbie* Lisa Daemon ?
Linuxhelp > Support > Technical Support
Hello, I am brand new to Linux. Suse 9.0 to be exact, and I love what I see. I have had a few problems that I am trying to sort out. I am hoping this would be a place to get help when I get stuck.

The biggest problem I am having right now is with Lisa Daemon. When I try to use Lan Browsing in Konquerer I get a message that says "The Lisa Daemon does not apear to be working". I have done an exaustive search on the net and have had no luck. There are a couple postings on other boards but, alas, they have not been answered. The few "newbie tutorials" that broach this subject are not "newbie friendly" (isn't that ironic). One thing that might be important is that when I click on the MyNetwork icon that suse installed on my desktop I get an unspecified error. Then Konquerer opens up. That is when I click on the Lan Browsing and get the message explaining that this Lisa is being lazy and she doesn't appear to be working. sleep.gif HELP how do I make her work. My goal is to use the Lan browsing to share files between the SuSE and an XP box. Which I have a pretty good tutorial on, but it doensn't say anything specific to this problem.

Thank you for all your help (in advance tongue.gif )
get a samba server going and Use LinNeighborhood
I'm not sure but I think I have Samba server going. I mean I know that it's installed.

When I start Konquerer there is a Lan Browsing tab that the SuSE documentation say's uses Samba to connect to other computers on the Network including Mac OS and Windows computers. The only problem is this Lisa Daemon thing.

The first thing to try is to run the command (as root in a terminal):

ps -ef | grep lisa

The result should be similar to this:
ps -ef | grep lisa
root      1971     1  0 06:13 ?        00:00:00 /usr/sbin/lisa -c /etc/lisarc
root      2027  1948  0 06:15 pts/1    00:00:00 grep lisa

If you get to return (or only the second line) then lisa is not running ... try the command:

/etc/init.d/lisa start

Then try the the

ps -ef | grep lisa

command again and see if lisa is running.
If lisa starts manually, but not at system startup, check to make sure you have it set to start on system startup.

Open YAST, click on System ... then Runlevel Editor ... then find lisa and highlight lisa and click the enable button.

While you are in the runlevel editor, go ahead and enable smbfs, smb and nmb. (Those are the samba services).

Any items that say No for enabled are not starting on system startup...

Press the finsh button and save your changes...
You also need to configure samba if you want to see windows computers ... Back in YAST, click Network Services and then configure Samba Client and Samba Server
That worked !!! well at least it stopped the Lisa Daemon not working error. I haven't finished configuring it to work with windows yet, but it works so far.

One thing though, when you said"

[/QUOTE]While you are in the runlevel editor, go ahead and enable smbfs, smb and nmb. (Those are the samba services[QUOTE]

I don't have smb or nmb in the runlevel editor. Is this a problem?
I don't have smb or nmb in the runlevel editor. Is this a problem?
Only if you want to use Samba biggrin.gif
It probably means that you don't have all the samba packages installed ...

Go to YAST, Select Software and then select Install and Remove Software ... In the Filter drop down box, select Search ... then type in samba and select search ....

I have everything except samba-vscan selected ... the items I have installed are:


Install all the software and you should be in business....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.