Help - Search - Members - Calendar
Full Version: X Server Wont Start On Runlevel 3
Linuxhelp > Support > Technical Support
ursus
Hello Guys,

Anybody knows where I can trace my error. ?

On runlevel 3 when I ran startx. the xserver wont start. which previously does. but when i use the superuser account on the same session the startx works okay.

Now on runlevel 5 everything seems to be okay.

Thanks in advance.
hughesjr
If you are going to startx from a session, you must login as that user from the console .... if you switch users (using the su - command) you can't startx ...

If you didn't do that (ie, if you logged into the console as a user, then typed startx without switching users) and it still doesn't work, see if you have a file named .xsession in the user's home directory ...

If not, create the file as a text file and add either this line for KDE:

exec kde

or this line for gnome:

exec gnome-session

then try again to startx.
ursus
thanks huguesjr.

i have fixed it I have a locked file inside my home directory under .gconf folder.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.