Help - Search - Members - Calendar
Full Version: Undefined Reference To `_res'
Linuxhelp > Support > Technical Support
iao
Hi people, I'm running mdk 9.2 with gcc 3.3.1 but having this problem when I try and 'make' bahamut through konsole. Can anyone help?

In function `init_resolver':
/home/iao/bahamut-release/src/res.c:136: undefined reference to `_res'
res.o(.text+0x76):/home/iao/bahamut-release/src/res.c:138: undefined reference t
o `_res'
res.o(.text+0x8c):/home/iao/bahamut-release/src/res.c:139: undefined reference t
o `_res'
res.o(.text+0x639): In function `send_res_msg':
/home/iao/bahamut-release/src/res.c:433: undefined reference to `_res'
res.o(.text+0x645):/home/iao/bahamut-release/src/res.c:434: undefined reference
to `_res'
res.o(.text+0x691):/home/iao/bahamut-release/src/res.c:441: more undefined refer
ences to `_res' follow
collect2: ld returned 1 exit status
make[1]: *** [ircd] Error 1
hughesjr
I had the exact same error when I tried to compile this using both Mandrake 9.2 and Fedora Core 1 ...

I also tried with gcc set to version 2.9.6 (the gcc-compat) with the same results ... not sure what it means.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.