Help - Search - Members - Calendar
Full Version: Cannot Find Dhcp Server *newbie Needs Help*
Linuxhelp > Support > Technical Support
quatapi
Hey!
I am running Corel Linux with Debian Kernel 2.2.12.
I am trying to put my box on the internet and my windows network.
I have a DSL connection(ethernet) to the internet and I have a 10/100 LAN/Ethernet card that I have installed.
The card is an F5D5000 and I managed by some miracle to get the rtl8139 module to become associated with it.
I've got Samba running just fine.
I configured my TCP/IP settings to connect to the DNS server I want it to, and I configured it so that I'm using a DHCP server.
The big problem is- whenever I apply the settings- it informs me that it cannot find the DHCP server and because that happend it cannot connect to the network. What am I doing wrong and how may I fix this problem? I'm kindof a newbie so any help would be appreciated.
thanks
hughesjr
are you using dhcp on your network (is that how your windows machines get ip addresses)?

Try assigning a static IP address on the same network as the rest of your window's PC's and see if that works ... are your pc's behind a firewall?
quatapi
Yes we are running a firewall but i disabled it and its still not connecting.
I tried static IP adressing but that isnt working either.
I called TDS metrocom support and they dont do linux. According to them it should find their DHCP server automatically.
I'm running a DHCP server on my windows comp on port 67 that is on the internet in vain hopes that the linux box will connect to it but as of now no success.
The windows settings are being evil and not letting me use windows's "share your internet connection" so instead im using that DHCP server program
what am i doing wrong ? its driving me crazy
michaelk
Explain your network. How does the linux PC connect to windows and to the modem? Any routers, switchs, hubs etc?
hughesjr
Is your DSL connection PPPOE? If so, you will probably need a newer distro / kernel than 2.2.xx.
quatapi
we have the network set up like this...

___________|DSL_modem|
_______________ |
_______________ |
_____________|switch|
________________|
______________|_|_|
_____________ |__|__|
_____________ |__|__|
____________ |___|___|
____________|___|____|
___________|____|____|
_______|win98| |linux| |win98|
ignore the long underscores - they are there to make the picture look like a picture

I put the command...

ifconfig -broadcast eth0 69.128.18.55

into the "console utility" and now it does not say "DHCP server not found" anymore, but it is still not on the windows network or the internet. I have no idea whether it is PPPOE or not but I will probably be looking into a newer kernel shortly if I can't fix this problem.
hughesjr
That is a pretty good picture !

Is the switch a switch or a router?

If it is a switch, how many IP addresses will your ISP allow your modem to pass through? You would need 3 seperate IP's in that setup (unless the switch is a router ... but it seems like it isn't since the IP you are using is real (69.128.18.55) and not an internal IP (10.x.x.x or 192.168.x.x). If you are limited to 1 or 2 IP's (from the ISP) then it won't work.

You can test this by turning off one of the windows machines and trying again...
quatapi
its a switch but,
im just gonna get a new kernel. The problem has to be how linux is interfacing eth0 with the DSL connection. Basically my kernel is from like 1999 and it doesnt know whats going on. Either that or i dont know how to tell it whats going on. We've had 4 comps connected to the network at the same time so i know its not an ISP issue.
thanks for the help
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.