Help - Search - Members - Calendar
Full Version: Kernel Recompile Problems...grrrr!
Linuxhelp > Support > Technical Support
jimmytango829
Hello out there... I hope someone can help me out a bit. I am compiling my first kernel (rather than use the packaged Slackware 8.1 one...a little bulky). I was having a fairly Linux-savvy friend walk me through it, but neither of us can figure out this wacky error. To start, heres my system:

Athlon XP 1900+
256MB PC2700 DDR Corsair XMS
MSI KT-400 MoBo
FSB set at 266 (the right one for that ram)

The CPU temp is at about 53 C and the case temp is about 50 C.

So I unpacked the source tree and set up a sym link to it from /usr/src/linux. Then, i did "make menuconfig" i picked and chose my options, and saved it. I then did "make dep" it continues for about 5-15 seconds and then gives me a segmentation fault followed by 4-5 "Error 2". I tried many different config settings with no avail. I also did different combinations of "make mrproper" and "make clean" before and after this compile, and no luck. Needless to say, make bzImage doesnt work. I also tried re-running "make dep" after getting the error, and it stopped in a completely different place with the same errors. Repeated attempts w/o deleting the previous compile attempts all yielded different places. Some even cause the kernel to "vomit" by stopping and displaying all the registers and the stack and some hex code (couldnt figure it out). I guess thats the short of it. I could embellish if you need some more info, but we'll see where you can get with this...

I'd really REALLY appreciate any help that people could give me with this, as I am completely stumped. sad.gif

Matt
Corey
Sounds like a problem I was having for a while. When I attempted to recompile my kernel, cc1 kept cutting out with errors, but it would never stop in the same spot. Finally after a few days of troubleshooting I found out that the problem was that the processor was over-clocked (??). The funny thing is, is that I never touched the bios in months, and it's password protected. The system was running over 200Mhz higher then it was supposed to, and it was causing general processor errors. If your system is overclocked (via yourself or any other way), set it back to it's proper clock speed and try it again.

This is most likely not your problem, but I thought I would give my 2 cents.
jimmytango829
Hey thanks for the reply... smile.gif I was thinking it just MIGHT be a hardware issue, so I'll try it out and see what's up.
Corey
...and btw, I have an AMD Athlon XP 1800+ , so you never know...
jimmytango829
I popped an extra fan in the case and manually set the ram timings (they were on auto) and everything seemed to work proper... Thanks!!! smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.