Help - Search - Members - Calendar
Full Version: Network Setup - Smc Etherez (8416)
Linuxhelp > Support > Technical Support
I'm having some problems with my network settings. I can't connect to the internet through linux and I could use some expert advice.

I believe I have a SMC EtherEZ (8416). It shows this in windows under networking as the hardware device. I'm using slackware 9.1. I'm using connecting to the internet via a comcast@home cable modem. When it's booting up I see this:

isapnp: Scanning for PNP cards
isapnp: Card 'SMC EtherEZ (8416)'
isapnp: 1 Plug & Play Card detected

When I do ifconfig -a I see:
lo Link encap : Local Loopback
inet addr: Mask:
UP LOOPBACK RUNNING ..after this it lists packets and errors and everything has a 0

I've tried modprobe tulip, modprobe epic100, modprobe 8139too, modprobe e100, modprobe eepro100. All of these have given me similar outputs for example:

/lib/modules/2.4.221/kernel/drivers/net/epic100.o.92: init-module: No such device
.. and then it tells me failed.

I've tried dhclient eth0, and dhclient lo0 but both of these said uknown interface: no such device and not found.

I've tried to do a cat /proc/isapnp but it says theres no file or folder.
I was also instructed to do a /proc/pci and a lot of stuff came up but nothing resembled my ethernet card.

I've tried netconfig with many different values (choosing DHCP) and I have had no success. I shouldn't have to put in an ip address, because every setting I have ever used has been autodetect and worked. When I load up GNOME (depending on what settings I put in) netconfig sometimes it tells me no connection found or something similar and asks to try again or go into GNOME anyway. I've switched to another virtual console while in GNOME and it has said Client 5 rejected from local host. Also, unlike in redhat, there doesn't seem to be a network configuration in a GUI environment.

If anybody could help out that would be great because I can't really tinker around without an internet connect to search for help on what I want to do. If you do respond please be newbie-friendly as I've only booted around 4 or 5 times and am still learning. =)

Thanks alot!


Oh, also I didn't have a problem in Red Hat 9.0 if that makes a difference. It showed the hardware device and I had it autodetect the settings and it worked.
Thinking I might need to install some linux drivers, I went to the SMC website and figured I'd try to take a look. I downloaded some linux drivers for EtherEZ (ISA). I managed to save the files on a floppy and copy the c file as the instructions told me to. It told me to copy the driver source code to a source directory such as /usr/src/modules. I created the modules directory using mkdir, and copied the c file in there. It then told me to compile the files using the compile command at the bottom of the driver source file which was:

gcc -D__KERNEL__ -Wall -O6 -I/usr/src/linux/net/inet -c smc-ultra.c

First of all it told me it couldn't find the file so I replaced smc-ultra.c with smc-ul~1.c because I had to copy it that way, but it didn't help. Also it had a problem with the directory, I believe it said no input directory? I don't understand why the included instructions aren't working, if this is even necessary, or what to do now. I was logged in as root. Could somebody help? =(
I manged to compile the c file (no thanks to the instructions). It then said at 'root' test the module by doing a "insmod driver.o". I typed this and said no such file or directory. I did a find / -name 'smc*' and a lot of differnet stuff came up. What looked most familiar was a:

I tried a:
insmod /lib/modules/2.4.22/kernel/drivers/net/smc-ultra.o
No such file or directory

and a:
insmod /lib/modules/2.4.22/kernel/drivers/net/smc-ultra.o.gz

This was followed by about 5 or 6 lines which talked about unresolved symbols being present. There is another text file included here which the instructions did not mention at all. I'm going to try to copy it into the same directory as the c file, and then recompile and see if I get any better luck. I'm guessing this won't help me very much, but if it does I'll make a post here. Otherwise, maybe somebody will have a suggestion for me in the meantime.
Well, it looks like I'm going to need to try yet another distro. But as a last resort I've posted the output of a few commands to see if that helps anybody figure out my problem.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.