Help - Search - Members - Calendar
Full Version: Dual Booting
Linuxhelp > Support > Technical Support
c3llph-aw4re
im trying to install mandrake on a computer with red hat already installed on it and i went through the installation successfully (there was one package that didnt install correctly, i dont remember which, maybe thats what went wrong) but GRUB did not recognize it next time i booted up. i assumed mandrake could use the swap space already set form the red hat 9 installation and deleted the extra swap space created during the mandrake installation. anyone know what could be causing this and how to fix it?
hughesjr
Some questions:

How many partitions are on your drive:

Probably 3 for redhat:

/boot
swap
/

and how many for mandrake? (one../ or two...boot, /)

Is the /boot for mandrake a seperate partition ... only a directory under / of mandrake ... or the same partition as redhat uses.
------------------------------------
How I setup dual boot linux machines is as follows (it's easier to maintain total seperation).

1. Install the main OS first ... it will control the MBR of the machine ... and I will manually modify Grub in this OS version (your redhat install would be this).

2. Install the second OS ... but in the install, make only a root partition and select the first swap partition as swap for this install as well. (don't do the default install and delete things later ... since you will have to manually edit the startup scripts and /etc/fstab later).

Very important - I like to set the second (and higher) OSes up so that they make their partitions (and not MBR) bootable for them (and since only a root partition is created, /boot is a directory of / and not a seperate partition). This allows the /boot directory of each OS to be seperate ... so when upgrading packages, grub from mandrake doesn't overwrite grub from redhat or slackware, the system maps aren't overwritten, etc.

3. Boot to the Main (first) OS (in your case redhat) and add an entry like this to the /boot/grub/grub.conf (assuming / for mandrake is /dev/hda5):

CODE
title Mandrake 9.2
    rootnoverify (hd0,4)
    chainloader +1


4. Now if you install SUSE with it's / partition as /dev/hda6 (and set it to share the swap partition, and create no boot partition ... and set the boot flag to /dev/hda6 instead of MBR).

5. Now you boot back to redhat, add this after the Mandrake install:
CODE
title SUSE 9.0
    rootnoverify (hd0,5)
    chainloader +1


6. Continue with the next OS....
c3llph-aw4re
ok i tried that and GRUB gives me "Error 21: Selected disk does not exist." i reinstalled mandrake with only one partition and in the boot loader settings in the mandrake install i told it to boot from hda5 (on an extended partition under hda4). i tried doing (hd4,0) and (hd5,0) in the grub configuration but neither worked

in the grub menu.lst file under my mandrake boot information i have as the first option:
CODE
title linux
kernel (hd0,4)/boot/vmlinuz root=/dev/hda5 devfs=mount acpi=ht resume=/dev/hda3
splash=silent vga=788
initrd (hd0,4)/boot/initrd.img


wewt okay i just put all that stuff in and it works now (so far)
hughesjr
I messed up the code in my first post ... it was supposed to be:

rootnoverify (hd0,4) and (hd0,5) .... not rootnoverify (hd4,0) and (hd5,0). I have updated the code sections of my previos post to correct it! (Sorry about that...)

The way you did it works as well (obviously, since you booted) .. but when you upgrade the kernel on the second install, you will have to manually change the values on the first boot's grub menu. If you get the chainloader working instead ... when changes are made to the second install, nothing will need to be changed on the master grub menu...
c3llph-aw4re
debian is giving me a bit of trouble, i tried the chainloader method in your previous post and that didnt work
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.