Help - Search - Members - Calendar
Full Version: Audio
Linuxhelp > Support > Technical Support
NewLinuxUserfromWindows
I have no sound. http://phuckfonix.antiskewl.com/snapshot3.png is what my device manager tells me. That's almost correct. I'm pretty sure it's Rockwell hardware.

Here are some folder and files names which were giving with the drivers for this card. This is a 98SE system I got this card with. Hewlett-Packard model 8650C. Here are some names I think might be useful: riptidehsf, riptide, Aud-Mod, riptide, my old MSg32.exe background task, Au8810, SBlaster

Now to get my audio working for Linux Redhat 8.0. I may be upgrading to White Box Enterprise Linux.
sprinthead
That looks a darn sight more like an Aureal 8810 card than anything else !

May wanna try checking the hardware database to see if it's supported or not !
hughesjr
Your sound card and modem are built on the same PCI card from HP ... it is a Riptide Audio/Conexant Modem Combo Card ... there is a place to get drivers for this card called linuxant.

First, use the Identify your modem link ... and once you get that working, then click the Riptide Audio Driver link and you should be able to get that working as well.
NewLinuxUserfromWindows
I don't know how to execute this shell script file. (listmodem.sh)
hughesjr
from within the directory where you put it type:

./listmodem.sh

If it doesn't start (and complains about permissions) then change the permissions with this command:

chmod 755 listmodem.sh

then execute it with:
./listmodem.sh
NewLinuxUserfromWindows
CODE
Desktop]$ ./listmodem.sh
=============================================================
=                  RESULT OF MODEM QUERY                    =
=============================================================

MODEM #1:
 PCI CONFIGURATION INFORMATION READ:
    Vendor Id         : 127A
    Device Id         : 4311
    Revision Id       : 1
    Sub Vendor Id     : 1235
    Sub Device Id     : 4311

 DEDUCED INFORMATION:
    Vendor Name       : CONEXANT
    Device Name       : HSF Data/Fax/TAM/Speakerphone (RIPTIDE)
    Modem Type        : HSF
    Download Site     : http://www.linuxant.com/


Following that, I downloaded the HSF 2.4.18-14 686 rpm. Ran that. Afterwards, read RIPTIDE and download the file witht he appropriate specs of my system. I ran and installed that. I still get the identical window I have a screenshot of(I confirmed it).
hughesjr
Do the command:

uname -a

And pick the version that matches your kernel ... if you already did that, then make sure to reboot (so that the new kernel modules can load.

what command did you use to install the RPM's ..

try:

[b]rpm -Uvh filename.rpm[b] (substitute the rpm names for filename.rpm)
NewLinuxUserfromWindows
CODE
root]# uname -a
Linux EDITED FOR FORUM 2.4.18-14 #1 Wed Sep 4 13:35:50 EDT 2002 i686 i686 i386 GNU/Linux


It appears that I can handle both i686 and i386 packages. They(HSF, RIPTIDE) are both currently installed. I know this because I tried - as instructed- to manually reinstall them . I usually chose automatic rpm installation that Redhat offers.Rebooting is an issue. I never properly shutdown. But, there is no situation where any of these particulare packages should finalize installation on shutdown?
hughesjr
No, they don't finalize on shutdown ... but the modules (drivers) load on startup ... so restarting should load the sound (and modem) drivers. (If the rpm modifies the /etc/modules.conf file).

I'm not sure what modules should load for those cards ... but you can look in the file:

/etc/modules.conf and see if there are any sound related drivers loading.

Also, you can use the command:

rpm -ql {rpm_name}

to see which files each rpm installed.

(Anything installed to /lib/modules/{kernel version}/ are kernel modules (that is, they are the drivers).

the command lsmod will tell what modules are loaded ...
---------------------------
just to make sure the rpm's are installed, do this:

rpm -qa | grep riptide

and

rpm -qa | grep hsfmodem

If those comeback blank, then install like this:

1. Download the files (hsfmodem-6.03.00lnxt03122800full_k2.4.18_14-1rh.i686.rpm.zip and riptide-0.6lnxtbeta03122800_k2.4.18_14-1rh.i686.rpm.zip).

2. Go to the directory that you downloaded the files to (in a terminal window as the user root) and install via these commands:

unzip hsfmodem-6.03.00lnxt03122800full_k2.4.18_14-1rh.i686.rpm.zip

unzip riptide-0.6lnxtbeta03122800_k2.4.18_14-1rh.i686.rpm.zip

rpm -Uvh hsfmodem-6.03.00lnxt03122800full_k2.4.18_14-1rh.i686.rpm

rpm -Uvh riptide-0.6lnxtbeta03122800_k2.4.18_14-1rh.i686.rpm.zip


--------------------------
If you still have no sound, post the results of:

rpm -ql hsfmodem-6.03.00lnxt03122800full_k2.4.18_14-1rh | grep /lib/modules

and

rpm -ql riptide-0.6lnxtbeta03122800_k2.4.18_14-1rh | grep /lib/modules

and the output of the command:

ls -al /lib/modules
NewLinuxUserfromWindows
CODE
root]# rpm -qa|grep hsfmodem
hsfmodem-6.03.00lnxt03122800full_k2.4.18_14-1rh
root]# rpm -qa|grep riptide
riptide-0.6lnxtbeta03122800_k2.4.18_14-1rh
root]# rpm -ql hsfmodem-6.03.00lnxt03122800full_k2.4.18_14-1rh|grep /lib/modules
root]# rpm -ql riptide-0.6lnxtbeta03122800_k2.4.18_14-1rh | grep /lib/modules
root]# ls -al /lib/modules
total 12
drwxr-xr-x    3 root     root         4096 Dec 29 10:53 .
drwxr-xr-x    7 root     root         4096 Dec 29 11:07 ..
drwxr-xr-x    5 root     root         4096 Jan  1 15:09 2.4.18-14


Is that the problem? I don't have any drivers installed because I'm recieving blank lines after -ql /lib/modles? To reinstall it manually I will try manual installs. I'm not able to reinstall until I uninstall. How do you proceed in the uninstallation? Maybe the manual installation will be properly installed.
hughesjr
rpm -e hsfmodem-6.03.00lnxt03122800full_k2.4.18_14-1rh

and

rpm -e riptide-0.6lnxtbeta03122800_k2.4.18_14-1rh

will remove the rpm's ... I can't install the rpms on my machines because I have compiled my own kernels. After a manual install, you should see any errors in the output text.

It is possible that they use a logical link from the /lib/modules/2.4.18-14 back to the drivers located somewhere else (in which case the rpm -ql will return blank, since the files are not written to /lib/modules/2.4.18-14).
NewLinuxUserfromWindows
This is during uninstallation.Both drivers were uninstalled from the same directory:
QUOTE
Removing hsf driver from /lib/modules/2.4.18-14/misc/


Installation:
QUOTE
rpm -Uvh hsfmodem-6.03.00lnxt03122800full_k2.4.18_14-1rh.i686.rpm
warning: hsfmodem-6.03.00lnxt03122800full_k2.4.18_14-1rh.i686.rpm: V3 DSA signature: NOKEY, key ID 5dfbf7dc
Preparing...                ########################################### [100%]
  1:hsfmodem              ########################################### [100%]
Conexant HSF softmodem driver, version 6.03.00lnxt03122800full

If you need license keys, assistance or more information, please go to:
        http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

Pre-built driver modules that seem compatible with your system were found under
/usr/lib/hsfmodem/modules/binaries/i686/rh/linux-2.4.18-14.

Automatically guessed region (using timezone): "USA"

Setting region for modem unit 0: "USA"

To change, use "hsfconfig --region" or "AT+GCI=<T35code>"
The current region can be displayed by entering "ATI9" in a terminal program.

Current parameters: ("hsfconfig --info")

Config for modem unit 0: /dev/ttySHSF0
        Device instance: 0-PCI-127a:4311-1235:4311
        HW revision    : Basic2 2.10 Standard DAA
        HW profile name: hsfpcibasic2
        Registration ID: .................REMOVED for forum
        License owner  : unknown
        License key    : FREE
        License status : FREE (max 14.4kbps data only)
        Current region : USA (T.35 code: 00B5)

The /dev/modem alias (symlink) points to /dev/ttySHSF0

To enable full 56K modem and FAX functionality, enter your license information
with "hsfconfig --license".

License owner and key data must EXACTLY match the information respectively
provided to and by Linuxant. Otherwise, license status will remain "FREE"
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.