Help - Search - Members - Calendar
Full Version: Wlan Access To The Internet
Linuxhelp > Support > Technical Support
Hello everyone,

I just installed a fresh copy of SuSe 9 Pro on my notebook computer and was trying to get a wireless card to work (dlink 650). I went through the Yast2 setup and even tried the kwifimangler, but all it has gotten me is the ability to ping the router and any other computer connected within my network. If I try to do a simple ping to say it comes back with an unknown host. The wireless card is set up as DHCP and is suppose to change the nameserver entries that the router pushes down (but this does not happen either). I have manually put in the nameservers restarted the wireless card (just in case) and it still only pings within the network. Now if I connect my eth0 to the router, it automatically changes the nameservers and I am able to ping whereever I want and surf the web. Anyone have some clue as to how I can get this to work? I would like to use the wireless of course!! Just as a sidenote, is the Intel mini-PCI card supported? Not really that important to me to get it to work since I have another card.

Thanks in advance.
Just for a test, can you manually assign an IP address and the DNS info for the wireless card and see if it works.

IF so, set it back to dhcp and try this:

If you can ping within the network and the only thing not working is DNS, try doing editing the file /etc/resolv.conf

add a line like this:


(substitute the IP address of your router for if it is different, then save the file)...

try a name lookup and see what happens....
I put a static IP on the WLAN, put the DNS entries in that DHCP spits back to me normally... But I can still only ping within the netowrk. If I try a ping with these settings ping comes back with "unknown host BLAH". I then got rid of those nameservers and put my router in and when I do a ping it comes back with "Network is unreachable". But when I connect a wire to my eth0 it all works perfectly, I can ping this or move to this page or that page and of course still cruise around the internal network. I have even looked at the /etc/resolv.conf file and copied it to a backup and used that when I shut off eth0 and turn on the WLAN. I am missing something here.... But I just don't know what. Is there any other information that would help with this?

Thanks again
DUH! Should have figured it out sooner! Since DHCP was not updating the nameservers and such, it never added a route to my router. All I had to do was

route add default gw wlan0

and it worked.... Now another silly question, how do I get this route everytime I boot up?

Thanks again.
Perhaps a better question is why, if DHCP did get me an IP address did it NOT update the routing table?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.