Help - Search - Members - Calendar
Full Version: Mounting Usb Mass Storage Device
Linuxhelp > Support > Technical Support
ahilliar
I am trying to mount both a usb flash drive and a digital 8track w/ compact flash card.

In the past I mounted the 8 track w/

%mount /dev/sda /mnt/mr8

but now it keeps asking for filesystem type when it never did before. The same thing happens w/ the flash drive. Once the 8track actually mounted but then when I tried to access the files (.wav files) linux just hung and I had to reboot. I also sometimes get an error saying that /dev/sda is not a block device.
I am unclear about how to find out which usb port is what in the /dev directory, e.g. /dev/sda, /dev/sdc, /dev/sda1.....

Also, when first booting up, if I type
%mount
I get the usual lines about hard drives and cdroms, but there is also an entry which says
usbdevfs mounted on /proc/usb
and I cant figure out what that is. That line is there even when there are no usb devices in and it just looks like a bunch of info about usbdevfs.

The frustrating thing is why would it sometimes give an error about not specifying fs type and sometimes not?

I dont know if this would be relevant or not, but I recently moved my computer across the room and when I plugged everything back in and rebooted linux all of a sudden doesnt detect my firewire card and gives an error about losing the IEE1394 controller during boot up.
I'm not at home now so I cant give exact error message, but if anyone thinks this is relevant say so and I will post it.
-Thanks
hughesjr
I would check the Firewire card is seated properly.

Have you added any software or hardware since it worked properly?

What is your distro?
ahilliar
I have redhat9.
I have not added any hardware, the only software I can think of that I've added is a gnome program for generating fractals, and I tried to install 3ddesktop but couldnt get it going.

I just tried
%mount /dev/sda /mnt/attache
and also
%mount /dev/sda -t vfat /mnt/attache
again for the usb flash drive (vfat because in windows it says fs is FAT), and both times I got an error saying that /dev/sda is not a valid block device. I dont even know what that means.
-Thanks
ahilliar
well, now for some reason I can mount the 8track again w/
%mount /dev/sda /mnt/mr8

But when I try to mount the flash drive w/
%mount /dev/sda /mnt/attache
(with the drive in the same usb slot that the 8track was plugged into)
I get an error saying no device found.

I have changed absolutely nothing w/ hardware or software since my first post, why in the world would I keep getting all kinds of different errors from the same exact command, and why would one of the devices all of a sudden work?
hughesjr
I am not much help with USB on Linux ... I only have a USB camera that I connect to my linux machine. It has always worked properly. HERE is a good book about Linux USB....and HERE is the Linux USB Project.

I also use a firewire DV camcorder, which also has also worked properly every time.

Sorry I can't be more helpful unsure.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.