Help - Search - Members - Calendar
Full Version: Installing Ut2k3 On Rh9
Linuxhelp > Support > Technical Support
untwisted
Hi everyone! Merry xmas and happy holidays.

Well, I'm a linux n00b. I just started using it INSTEAD of windows just this past week. So far, so good. I'm learning a lot, and I'm liking everything. The only problem is that I can't get my games installed! I know that Ut2k3 will work without a windows emulator, and everything looks good till I start to install it. When I run the linux_install.sh file on the 3rd CD (thats what it tells me to do), this happens:

[root@localhost cdrom]# ./linux_installer.sh
Copying to a temporary location...
Verifying archive integrity... All good.
Uncompressing Unreal Tournament 2003 for GNU/Linux 2107......................................................................

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)
/dev/fd0: Invalid argument
mount: block device /dev/fd0 is write-protected, mounting read-only
[root@localhost cdrom]# /dev/fd0: Invalid argument
mount: you must specify the filesystem type



ack! What do I do? I *THINK* that the game continues to install. THe progress bar doesn't move, but the file names change every so often. And it asks me to mount the first CD. If it is installing, it is doing so INCREDABLY slowly (I let it run for about 5 hours to see if it might just be a GUI error).

Does anyone know what I can do? I've tried updating AND downgrading the GTK+ but that doesn't work.

Thanks!

-Brian
untwisted
I guess no one has any ideas? :-/
EliteX
What make of Linux are you using? What version Kernel? Is the game a Windows CD that you're trying to install on Linux? If so, did you try looking here for binaries? Please give all the information you can about your OS and the game.
untwisted
I'm running RedHat 9, and I'm not sure about the kernel version, and i'm not sure how to check. It says redhat 9 and I saw shrike somewhere (if that helps). It is a game that has 3 CDs. The game devs put a linux installer on the 3rd CD. When I try to run the installer I get the errors I showed above. Thats pretty much all I know. I hope that it helps.
EliteX
Try finding the update function on your RedHat, I've never used it so I don't know where it is. On Mandrake its under Configuration>Configure Your Computer, from there you *should* see the option to update your OS. If its complaining about the GTK+ version being too old, then it needs to be updated, the update option on Linux should do that (if you tell it to update that specific package). Also, try looking here for pretty detailed directions on how to install Unreal Tournament 2003 on Linux. Try updating before anything, I can almost guarentee that it will solve the version problem.
untwisted
I ran the updater, it downloaded and installed all the updates it could find, and still no go. Still the same error/warning. I had already tried updating the GKT+ anyway. Well, does anyone else have any ideas?


Edit: It might be beneficial to tell you that the install starts to work until it gets to a file called extras/ip_passthru.pl that is where it stops at and begins to take a long time. I KNOW it can't be the CDs because I've used them before to install to windows.

Thanks,
Brian
untwisted
SOLVED!!! The Gtk+ Warning really didn't matter after all! It was the mounting / unmounting of the drives that was screwin the install up! This article is the best I've found on installing ut2k3, and if anyone else has problems, this is the article to read.

http://www.linux-gamers.net/modules/wfsect...hp?articleid=18

THanks for your help!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.