Help - Search - Members - Calendar
Full Version: Not Enough Space?
Linuxhelp > Support > Technical Support
I am trying to DL a copy of Oracle8i but everytime I get to the 118 meg point the DL stops and then an error comes up telling me I dont have enough space, yet I have 20 gigs free. I am running Red Hat Enterprise Linux ES Release 2.4.9 and really getting frustrated here. Am I an idiot? I feel like one. Thanks for the help.


How are you trying to download it (ftp, web browser etc)?

Can you run dh -h and paste the results here.
Ah forgot to say that my bad. I am trying to DL it with Mozilla. I have also tried it with Netscape and gotten the same results. I tried to run dh -h but command was not found. If you can't tell I'm quite new to this so pls excuse me if i forget something important.


/bin/df -h
Here is what I got when running df -h. I have plenty of space yet i cant DL anything over 118 mb.

Filesystem Size Used Avail Use% Mounted on
/dev/sda6 372M 215M 138M 61% /
/dev/sda1 45M 8.9M 34M 21% /boot
/dev/sda5 10G 34M 9.7G 1% /home
none 502M 0 502M 0% /dev/shm
/dev/sda2 20G 1.8G 17G 10% /usr
/dev/sda7 251M 40M 198M 17% /var
The only thing i can think of is that it's (mozilla/netscape) downloading the file to a tmp folder (/tmp) and since your / partition is almost full that is why you're receiving the errors.

You can try moving your /tmp dir to another partition such as /usr/tmp and then creating a symbolic link from /tmp to it
I followed your suggestion and moved the /tmp dir but I still get the same problem. When looking at permissions noone but root had permission to write to temp so I changed that to everyone and still it stops at 118 mb. Could this just be a problem from a bad installation?

We think your problem is that there is only 138M left on the / partition (where tmp is)....

See if you have a /usr/tmp directory:

ls -al /usr | grep tmp

Here is my output:

lrwxrwxrwx    1 root     root           10 Oct 18 01:44 tmp -> ../var/tmp/

My /usr/tmp points to /var/tmp (which wouldn't help you at all ... you only have 198M left in /var)

so for ease (and since you have plenty of room in /home, do this .... )

mv /tmp /home/

There should be no errors in this command.... now make sure /tmp is in home ... and not in / ... which these commands:

ls -al / | grep tmp

(should be blank)

ls -al /home | grep tmp

should show something like this:

drwxrwxrwx    2 root     root         4096 Dec 25 08:44 tmp/

If it is a directory (like above) ... that is good, if it is a link {tmp -> /var/tmp .... as an example} then delete the link {rm /home/tmp} ... and make a new directory {mkdir /home/tmp}.

if the permissions of tmp are not rwxrwxrwx, do the command:

chmod 777 /home/tmp

then issue the command:

ln -s /home/tmp /tmp

Now check that /tmp points to /home/tmp like this:

ls -al / | grep tmp

The output should look like this (except for dates)

lrwxrwxrwx    1 root     root           10 Dec 25 09:20 tmp -> /home/tmp

Then you should be able to download....
Ok that got it. Thanks alot.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.