Help - Search - Members - Calendar
Full Version: Installation Problems
Linuxhelp > Support > Technical Support
sshekhar
Hi All,

I need some help intalling Red Hat on my system. I have an ASUS k7m motherboard and have just installed an 80 GB Western Digital hard drive in it (model WD800JBRTL). I started by trying to install Windows 2000 to get a dual boot system. But always ended with kernel exception in it (blue screen). Then I gave up on it altogether. I have been trying to install Linux Red Hat 9 for the past 2 weeks now. Everytime I install it gives me a
"Kernel Panic: 48:05
VFS Unable to mount root FS
Try with a root= option"

I don't understand how the kernel cannot mount root FS after uncompressing the kernel image. I have a small NTFS partition of 256 MB on the hard disk. My hard drive is good, I tested it thoroughly. I got the three iso-shrike's from red-hat's website. Performed md5 checksums every step of the way. I have tried giving all parameters possible to kernel. I still keep getting these problems. Can anyone provide any insite into why this is happening?
hughesjr
Make sure you have the latest BIOS ... see this FAQ about that board:

K7M Large Drive

Be careful .... and make sure you get the right bios .. .there is a K7M and a K7M-RM...

Here is the download page for K7M...you would need the files km132.zip and flashk7m.exe.

Also if you have sound problems in linux there looks to be a sound driver there as well...
sshekhar
I am using RedHat's 9.0 graphical installation interface. During installation I go through all the way to setting up the root password. But once the "packages extraction" is reached "Anaconda" crashes. One time I was able to install about 420 of 435 packages. During that installation when RedHat got to installing the source code of linux it crashed. After that I have tried several times to reinstall the entire thing, but everytime coming to packages extraction "Anaconda" crashes. I was hoping that since "/boot" has the kernel image I should be able to boot off the hard-disk. But the bios comes to IDE-0 and says "OK" and then hangs there. I am guessing MBR was not written properly during the last installation crash. Thanks a bunch in advance. An aside, I have run "media check" on each of my disks and they are all fine.
hughesjr
I would recommend that you try install like this (type this instead of pressing enter at the first prompt when booting from the cd):

linux apm=off noapic nousb nousbstorage

If that doesn't work, try a text install:

linux text apm=off noapic nousb nousbstorage
sshekhar
Thanks for your response. I tried your suggestions and still keep getting problems when anaconda reads the package information. This is what I tried:

a.) linux apm=off noapic nousb nousbstorage
Went into the Graphical Installer and all the way through to "Reading Packages" when it produced an "Unhandled Exception". I tried to save it on the disk, but it didn't work. Anyhow I copied the first and last lines of the trace back as below:
"/usr/lib/anaconda/gui.py, line 761, in nextClicked self dispatch"
........ (A whole bunch of other lines here)
File "/usr/lib/anaconda/comps.py" line 171 in _getitem_ KeyError: XFree86-libs

b.) Then I tried the Linux text boot using:
linux text apm=off noapic nousb nousbstorage
This gave me a "received Signal 11" message and killed the installer

I have two other observations during my installation that I would like to clarify:
a.) When anaconda starts probing hardware it finds my "Rage" videocard but then goes on to say
unknown monitor type. It finds a "Generic wheel mouse". How could the installer not get the information
about the Monitor type when it can probe the video card properly?

b.) I get the following configuration for my partitions:
/dev/hda1 /boot (ext3)
/dev/hda2 / (ext3)
/dev/hda3 swap

GRUB is configured to sit in the MBR. However, Linux installer
sshekhar
Sorry about abruptly finishing the last post. Continuing on the last question of my previous post:

GRUB is configured to sit in the MBR but installer states that it will try to boot partition "/dev/hda2"
which happens to be the mount point "/"
I am wondering shouldn't this be "/boot" where the kernel image is located.

Thanks a lot in advance for all your help.
hughesjr
I think the grub info is OK ...

The monitor is probably OK as well ... if it doesn't know the Monitor, it will use VESA, which should be OK.

Maybe try a text install:

linux text

but without any other switches....

It seems to me like a problem reading the CD or writing to the hard drive.

Maybe try writing another CD-1...
azepromidi3000
hey guys I have a problem now with my Red Hat Enterprise.

I have dual boot with windows 2003 sever , And found out that windows 2003 doesn't like having Red hat linux on it the same machine.

as i boot into Red Hat Enterprise ws i lose sound and my videro Card doesn't show a picture is there any way to fix this problem.


no sound drives
or no videro drives it can get.
sshekhar
Hello Again,

I tried simple text booting using "linux text", but ended up with a Signal 11 due to which anaconda crashed. I looked up online and the consensus is that it is definitely due to either the caches and/or memory. So I got memtest86 from its web-site to see if my memory was bad. I ran the test and hell broke loose. The results were that I have tons of errors in my memory. Each time I ran the memtest86 I got different results on the errors. I am wondering whether to trust this test result. I use to run Windows 2000 on this same memory without a hitch.

Thanks in advance for any help.
sshekhar
IT WORKS!!

I was able to install RedHat 9. Turns out I had two 128 MB RAM sticks. One of them did not past the "memtest86". I took it out and anaconda worked perfectly.

Anyhow, I think my network card is not installed. It is a "Linksys 10/100 T", gave me some message during boot "Check your network cable". During installation I had picked network configuration using "DHCP". When I check to see my "routing table" using netstat -rn, all I get is the name of the local loopback interface ("lo") in the list of "interfaces". How do I find out for sure whether the card is installed or not? Also where is the boot log located?

I think I am going to enjoy linux. Thanks a bunch for all your help.
hughesjr
you can use redhat-config-network (from the command terminal in GUI mode).
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.