Help - Search - Members - Calendar
Full Version: Dont Know How To Install Sound
Linuxhelp > Support > Technical Support
I have a download version of Linux Mandrake 8.1, which I have installed before to play around with. I was amazed at the stability and layout of the KDE interface. I am as newbie as it get when it comes to the Linux OS! I figured out how to use Amsn and I was proud. I got my cable Internet working, Linux did that on its own. I've finally decided to throw Windows to the curb, I want to run Mandrake 8.1 on both of my computers. But, I want sound! One of my machines is a Packard Bell Pentium 233MHz, the other is a machine I built myself, which is a Pentium II 450MHz. I know Linux will run on both, because I've installed it on both in the past. The only reason I went back to Windows is because I can't figure out how to get my sound to work on either of them. One guy I asked went on about modules, which went right over my head. One sound card is a Yamaha OPL3-SAx WDM, which is an onboard sound card in the Packard Bell. The other sound card is an OPTi Audio 16 sound card, which is in an ISA slot, I believe (the really long brown slot). If someone could give me step by step instructions on how to get these working, I would be greatly thankful. I will forever be a Linux user, if I can have my sound! Thank you for taking the time to read this, and thanks in advance for anyone who might be able to help.
ISA soundcards are fairly hard to install ... PCI cards have plug and play and are much easier.

Modules are how kernel drivers are loaded ... and especially when dealing with ISA cards, there may be alot of testing and tweaking to make it work.
For the opl3sax card try this command from the command line as root:

modprobe opl3sa2

See if your sound works .. if so, we can make it load all the time...if not then:

post any output to that command and anything in the output of:

dmesg | less


For the OPTi Audio 16 card do:

modprobe mad16

same routine, check the output of the command and dmesg | less...

What will definatly help is if you have the current info about the things like:

io=0x530 irq=5 dma=0 dma16=0 mpu_io=0x300 mpu_irq=9 joystick=1

Basically ... go to the windows device manager and write down anything it says and post it here (mem location, irq, dma, etc...)
For the
Do I type the modprobe "opl3sa2" in the Shell? And, where do I look for the dmesg | less stuff? I'm a total newbie, so I need step by step, if you can provide it. I appreciate the repsonce, and hope you can continue to help me. I really want my sound!
Yes, sorry about that... wink.gif

All the commands I give you to do should be in a terminal window (or the console) as the root user.....

in the terminal, you would type:

modprobe opl3sa2

ALSO the command:

dmesg | less

would be typed in the terminal...

Also, the commands are for the current booting of the machine only ... if you restart the machine, you will have to redo the modprobe opl3sa2 command...
First I'd like to say thank you for taking the time to help me with this, and hope you stick around until I get this dealt with, once its sorted I'll be greatly thankful. I'm making sure to write all this down for future reference. However, I have a (stupid?) question, I see a lot of 'you need to be root' when I try to do stuff in the Shell. How do I be root? I tried logging off, but it still tells me the same thing.
Ignore the previous reply about how to become root, I figured out the 'su' command for temp root.
For the modprobe mad16 I got the following:
# modprobe mad16
/lib/modules/2.4.8-26mdk/kernel/drivers/sound/mad16.o.gz: init_module: Invalid argument
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.8-26mdk/kernel/drivers/sound/mad16.o.gz: insmod /lib/modules/2.4.8-26mdk/kernel/drivers/sound/mad16.o.gz failed
/lib/modules/2.4.8-26mdk/kernel/drivers/sound/mad16.o.gz: insmod mad16 failed

For the modprobe opl3sa2 it didn't say anything, but when I tried to play an mp3 it didn't make any sound.

Any ideas?
On node 0 totalpages: 65520
zone(0): 4096 pages.
zone(1): 61424 pages.
zone(2): 0 pages.
Kernel command line: auto BOOT_IMAGE=linux ro root=301 devfs=mount quiet
Initializing CPU#0
Detected 451.033 MHz processor.
Console: colour dummy device 80x25
Calibrating delay loop... 897.84 BogoMIPS
Memory: 254824k/262080k available (1086k kernel code, 6868k reserved, 397k data, 712k init, 0k highmem)
Dentry-cache hash table entries: 32768 (order: 6, 262144 bytes)
Inode-cache hash table entries: 16384 (order: 5, 131072 bytes)
lines 1-21
Mount-cache hash table entries: 4096 (order: 3, 32768 bytes)
Buffer-cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
CPU: Before vendor init, caps: 0183f9ff 00000000 00000000, vendor = 0
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After vendor init, caps: 0183f9ff 00000000 00000000 00000000
CPU: After generic, caps: 0183f9ff 00000000 00000000 00000000
CPU: Common caps: 0183f9ff 00000000 00000000 00000000
CPU: Intel Pentium II (Deschutes) stepping 02
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfdb91, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router PIIX [8086/7110] at 00:07.0
Limiting direct PCI/PCI transfers.
isapnp: Scanning for PnP cards...
isapnp: Card 'OPTi Audio 16'
isapnp: 1 Plug & Play card detected total
PnP: PNP BIOS installation structure at 0xc00f79b0
PnP: PNP BIOS version 1.0, entry at f0000:73ae, dseg at f0000
PnP: 11 devices detected total
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.14)
Starting kswapd v1.8
VFS: Diskquotas version dquot_6.5.0 initialized
devfs: v0.115 (20010827) Richard Gooch (
devfs: boot_options: 0x1
vesafb: framebuffer at 0xe0000000, mapped to 0xd0800000, size 32768k
vesafb: mode is 800x600x16, linelength=1600, pages=33
vesafb: protected mode interface info at c000:4c50
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
Console: switching to colour frame buffer device 100x37
fb0: VESA VGA frame buffer device
Detected PS/2 Mouse Port.
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
block: queued sectors max/low 169018kB/56339kB, 512 slots per queue
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:pio
hda: WDC AC23200L, ATA DISK drive
hdc: 56X CD-ROM, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: Disabling (U)DMA for WDC AC23200L
hda: 6346368 sectors (3249 MB) w/256KiB Cache, CHS=787/

This is all the stuff the 'dmesg | less' brought up, I don't know how much you wanted of it, so here it all is. I typed this after typing in the modprobe opl3sa2 command.
On the 450 mhz machine ... it looks like it found the card...

isapnp: Scanning for PnP cards...
isapnp: Card 'OPTi Audio 16'
isapnp: 1 Plug & Play card detected total

So on this machine, you should have sound....

what does the command


show on the 450 mhz machine...
Here is what it brought up, I tried /usr/sbin/sndconfig and the first time it ran it seemed like it worked, the sound tests it played I could hear. But, then I closed the terminal window, and it stopped working. So, I opened a new one, and now it gives me the same error stuff it gave me for the modprobe mad16. Then I noticed that the sndconfig was actually using mad16 when it worked the first time, so I used the modprobe mad16, and it worked for the sounds on Amsn and Unreal Tournament, but I couldn't play music. I tried audio cd, and mp3. Now, I rebooted, and there's no sound again, and the modprobe mad16 doesn't work now. So, now I'm back at square one, or I'm missing an obvious key. I don't understand, once I get it working, if I'm allowed the close the terminal window?, do I have to type that command everytime I reboot?, and I don't understand why it won't play music. And now, as I type this I ran the sndconfig again, and the sound is on, but no music. Seems a little screwy to me. Thanks again for the help.

# lsmod
Module Size Used by
nls_iso8859-1 2880 1 (autoclean)
nls_cp850 3632 1 (autoclean)
vfat 9968 1 (autoclean)
fat 32192 0 (autoclean) [vfat]
r128 86432 1
agpgart 26752 3
af_packet 12560 0 (autoclean)
keybdev 1920 0 (unused)
mousedev 4192 1
hid 18480 0 (unused)
usbmouse 2048 0 (unused)
input 3648 0 [keybdev mousedev hid usbmouse]
usb-uhci 21232 0 (unused)
usbcore 50752 1 [hid usbmouse usb-uhci]
8139too 12704 1 (autoclean)
rtc 5600 0 (autoclean)

The first part is to figure out the correct module. It looks like we have done that...that's good.
As for music as played through the CD's audio player, that requires a cable connected between the audio out on the CD-ROM and the aux input (sometimes labeled CD in) on the soundcard. Do you have the audio cable connected between the soundcard and the cdrom drive?
MP3's are not supported out of the box by RedHat due to a required fee ... I'm not sure about mandrake 8.1 ... but we can maybe fix that later ... remind me again if it doesn't work after we get finished.
When we get finished, sound should start when you bootup, no need for typing in anything by hand ... but with ISA cards it is a little harder than with a PCI card.

Post the contents of the file /etc/modules.conf and /etc/modules ...
How much memory is in the 450 MHZ machine ... mandrake 9.2 has harddrake which is much better at detecting hardware...(do you have a cd burner and broadband and could easily download it)? You need at least 128mb RAM to try mandrake 9.2.
I have 262MB of RAM in the computer, I plan on upgrading to 512MB soon, hopefully. Yes, I have the cable that ties the CR-ROM to the sound card, the CD audio plays, its just the MP3 music that wouldn't. I do have broadband, and I'm working on getting a burner. I've been wanting Mandrake 9.2, just waiting on the burner. People keep telling me that Mandrake sucks and I should get RedHat 9. But, I'm getting used to Mandrake, so I'll stick with it. Also, I found patches to play my Quake 3 and Unreal Tournament games on Linux, and the sound plays when I play them also. So, I'm pretty sure that mad16 is my key. I just need to figure out how to make it automatically know that when it boots. I don't mind having to type it in, if thats what needs to be done, but if there's a better option, I'm all for that too. What would you recommend as far as RedHat or Mandrake, before I download anything? I'm looking for something stable and easy to use. I like to have a GUI to work with, I don't know many commands yet. Thanks again for all the help, the sound works, I just need to automatically load the module now. After that, I won't bother you anymore. tongue.gif
I have another question, is it possible to download the new Mandrake to another hard drive, and run it like that? If so, could you tell me how? Thanks!
Mandrake 9.2 and FedoraCore1 (the new RedHat) are very similar .... They both work very well.

If you like how your mandrake feels, I would say to stay with it.

The one main advantage (and disadvantage) about fedora is that it has a very short release cycle ... and they are continually adding new items (not just security updates, but new versions as well). This makes for a system that has newer and more cuttying edge items ... but also requires more work to maintain as new versions sometimes require lots of work to use older data.

Both mandrake and redhat/fedora are fairly easy to install ... but since you've done the mandrake install at least a couple times, mandrake has the advantage there.

I just advise current redhat users to use fedora and current mandrake users to use mandrake when they upgrade.
Yes, you can install mandrake from another hard drive ... but it is good to have the 1st CD handy to use as a rescue CD incase something goes wrong...

If you PM me with your mailing address, I 'll burn you the 3 Mandrake 9 CD's (and the Fedora Core 1 CD's) and put them in the mail for you (if you are in the US).
I just wanted to give one final thanks for all the help, I've learned a lot just through setting up sound, believe it or not I learned a good 4 or 5 commands from it. Plus, I got my sound! Thanks a lot, you did an awesome job helping me through it. Keep up the good work! smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.