Help - Search - Members - Calendar
Full Version: Audio Card Help
Linuxhelp > Support > Technical Support
Jim
I recently re-installed Linux so that I could re-partition the hard drive and switch to KDE, however, now I am finding that I can't get any sound. I spent most of the afternoon struggling to get Xine installed and when I finally got it working I don't hear anything. I did the auto probe for my sound card and it says it finds it (my Vendor nVidia Corp Model: Force2 AC97 Audion COuntroler (MCP) Module: i810_audio) is what is shows me, wich is right as far as I can tell, but the test sound doesn't work. Of course I have checked all the obvious things like my speakers are plugged in and what not. I don't understand, I could get sound before when I was using GNOME (not that the desktop should have anything to do with it) but hey, who knows? So any help would be great grand and wonderful.

Jim

I should note that I am using Red Hat 9 fully up2date
hughesjr
Does your motherboard use a nforce2 chipset? ... if so, you must download and install the unified driver from nvidia ... and you have to install it for your specific kernel...

Have a look at this thread ... don't do the video portion unless you have a gforce video card....
Jim
*screams of bloody murder and death*

Ya, installed the packets, fine. (I allready had the latest kernel)
Changed the permision, fine.
Changed the 5 to 3 DEATH!!!!
When I reboot it stopps in the middle of the loading processes.
It says "Going to level 9 init" or something like that, and than "No proccesses in level 9" and just stops there, I can type and what not, of course nothing happens. HOLY CHRIST! What did I do? And is there any hope in Linux heaven of fixing it? PLEASE SAVE ME!
Jim
Ok, whew, sorry about my last post, I wasn't really in a civilized state, ok, I got it under control. I was able to boot up into rescue mode and find my typo in the inittab file. Ok, so I did all that and ran the IGNORE_CC...... function, so first it asked me if I wanted to download the stuff from NVIDIA and if I click yes it freezes, and if I click no it goes on to try to build a module it's self I guess but it says my Kernel Header files don't match my kernel. So what should I do now? Ya, I am helpless, but I am learning.
hughesjr
sounds like you typed a 9 instead of a 3 ... or maybe 35...

either way, you should be able to boot from the redhat cd 1, when you get to the boot: prompt, (where you normally press enter to install), instead type:

linux rescue

and press enter ... go through the screens(keyboard, language, no network interfaces, select continue to mount the partitions, etc.) then goto /mnt/sysimage/etc

now use vi to edit inittab and make sure to change:
id:9:initdefault:

to

id:3:initdefault

and save it, then reboot.
hughesjr
Cool ... you figured out the boot disk on your own!

you need to type this (all in one line):

IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-4496-pkg2.run

(from with the directory where you downloaded the file NVIDIA-Linux-x86-1.0-4496-pkg2.run to)...or you could type

export IGNORE_CC_MISMATCH=YES

then

./NVIDIA-Linux-x86-1.0-4496-pkg2.run
hughesjr
also make sure you have kernel source installed ... and go to :

cd /usr/src

ls -al


If there is no linux link pointing to your kernel source directory, type this command:

ln -s linux-2.4.20-20.9 linux

(substitute your linux-2.4.20-xxx directory for 2.4.20-20.9)

so that the command:

cd /usr/src/linux

opens to your source directory...
Jim
Ya, great, except you lost me. I need to know a couple things. All from the last one. I need to know how to figuere out were my kernel source directory is. Than I need to know how to tell if there is a linux link pointing to it (if bet if I knew were it was I could figuer it out, but humor me). Um, thats probably it, could you give me an example of what the link command might look like with inserting my kernel source directory in it?

That, and I just have to say you guys are great, you handle us stupid newbies pretty well, ok, maybe that was an over generilization, not all of us newbies are stupid. But o well. So ya, let see how late you guys stay up, I am a stupid college student, I will be up for along time still.
hughesjr
The kernel source directory is in /usr/src

It is a directory and it's name is linux-x.x.xx-xxx where x.x.xx-xxx is the kernel version (my redhat install on an x86 machine with the latest RH kernel source is /usr/src/linux-2.4.20-20.9. I also have a 2.6 kernel installed that I am currently using.

In linux, you can do something called a logical link ... it is basically a pointer that allows a directory or file to point to another location ....

Most software that compiles against the kernel source expects it to be in the location /usr/src/linux ... so that requires a link be created in /usr/src (that is named linux) which points to the kernel source directory....if you go to the directory /usr/src and type the command ls -al you should see all files and directories in /usr/src ... mine (on my RH9 machine), looks like this:

QUOTE
[root@RedHatTest src]# ls -al
total 24
drwxr-xr-x      6 root    root        4096 Nov 20 19:45 .
drwxr-xr-x    16 root    root        4096 Nov 28 05:27 ..
lrwxrwxrwx    1 root    root            25 Nov 20 19:45 linux -> linux-2.6.0-0.test9.1.93/
lrwxrwxrwx    1 root    root            17 Nov 17 20:23 linux-2.4 -> linux-2.4.20-20.9
drwxr-xr-x    16 root    root        4096 Nov 17 20:23 linux-2.4.20-20.9
drwxr-xr-x    20 root    root        4096 Nov 20 20:59 linux-2.6.0-0.test9.1.93
drwxr-xr-x      7 root    root        4096 Sep 17 16:59 redhat



linux is a link pointing to the directory linux-2.6.0-0.test9.1.93/ ... linux-2.4 is a link pointing to the directory linux-2.4.20-20.9. On my machine, if I type the command cd /usr/src/linux I will go to /usr/src/linux-2.6.0-0.test9.1.93/.

What you need to do (from within the /usr/src directory) is see if you have a link created (named linux) that points to your source directory ... probably something like linux-2.4.20-20.9). If you don't have a Linux link the command would be (from within the /usr/src directory):

ln -s linux-2.4.20-20.9 linux

(if you kernel source is named linux-2.4.20-20.9)

If you linux link, but it is pointing to the wrong directory (like mine is if I wanted to compile something for the 2.4 kernel instead of the 2.6 kernel), then you would do this:

rm linux

then

ln -s linux-2.4.20-20.9 linux
Jim
This is probably why I am confused, when I type in list all at the scr directory this is what I get back

QUOTE
[root@x101-198-8-dhcp src]# ls -al
total 20
drwxr-xr-x    5 root    root        4096 Dec  1 23:41 .
drwxr-xr-x  15 root    root        4096 Nov 30 17:09 ..
drwxr-xr-x    2 root    root        4096 Jan 24  2003 debug
drwxr-xr-x    3 root    root        4096 Dec  1 12:52 nvidia
drwxr-xr-x    7 root    root        4096 Nov 30 17:23 redhat


so any ideas on where else my kernel might be? Does it make a diffrence if it was installed automatically with up2date and not by an rpm? When I tried to install the new kernel rpm that was on the thread you sent me to it said it was allready installed. Thank you for your help.
hughesjr
I don't think you have the package called:

kernel-source-2.4.20-20.9.i386.rpm

installed...

do the command:
rpm -qa | grep kernel-source

if it is blank then you have to install the kernel-source package...Download the above package and install via this command:

rpm -Uvh kernel-source-2.4.20-20.9.i386.rpm
Jim
I could have sworn that it told me I had already installed that rpm but what ever. So I installed it, ran the Nvidia configuation tool and everything, but I still don't hear a test sound when I have it auto detect my sound card. I am going to go back over some stuff and see if I can figuer anything out but I am really quite helpless on this. In the Control Center, if I go Information--sound it tells me 'there is no information available about soundcard' So I don't know.

As an interesenting (but not that suprising side note) I think I am one step closer to getting my dual monitors working. No instead of a crappy test pattern it doesn't send a signal to the other screen and the monitor shuts itself off. I am fairly convinved that the problem might have to do with linux not recognizing the 'Xinerama' command. Its not under the list of supported option in the X-server screen in control center. I am running a 4.x version of X but I don't know. So is there any way for me to check and see if Xinerama is suported?
hughesjr
So ... you got the Sound and Dual Monitors working?
Jim
actually, I still don't have sound working, I am been messing around with ALSA but haven't gotten it to work yet. I haven't had much time to play in linux with finals comming up. I acedently placed the proclomation about dual monitors in this subject, I would have deleted it but I don't have that power.

So ya, I still can't get sound working, even with all the latest NVIDIA drivers in. I realized that I actualy never had sound working in linux before I re-installed like I claimed to have, I just get sound when I play CDs, wich doesn't pass through linux and the drivers, it just goes staight out the optical out in the back. So I would still like any help about the sound card issue that could be given.
hughesjr
OK ... I deleted the Dual Monitors post for you.

The 1 of the 4 rpms in this thread (referenced earlier) is the Unified Driver for the nforce2 chipset.

If your board has that chipset, the built-in audio card works after installation of the RPM named NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm. (As does the built-in network card).

There are instructions in the above post and HERE on how to install the RPM ... it requires that the 2.4.20-20.9 kernel be installed.
Jim
No, I installed that, because thats the only way the the drivers for the video card would work and I got that working, it still doesn't want to have my audio work after installing the rpm. Thats the issue.
hughesjr
OK ... what does the command:

lspci -v

say about the audio device.
Jim
ok, so lspci -v gives me back this

QUOTE
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
        Subsystem: Hewlett-Packard Company: Unknown device 12b9
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
        I/O ports at 3000 [size=256]
        I/O ports at 3400 [size=128]
        Memory at fc302000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2


But now I cam getting sound from my system speaker, and by system speaker I mean the serious speaker built into the chasi not just the crappy one that beeps, except the problem is, that its suposed to be muted when something is plugged into either the headphone out or the speaker out, and its not doing that, its actually not even sending anything out the speaker out, but it is the headphone out.

If I go into the it acutally shows stuff under Information/sound I would put the whole thing in but I can't cut and paste. The importat things seem to be "Installed Drivers: Type 10: ALSA emulation" and "Card config: OmniVision Technologies, Inc, USB Camera at usb-00:02.1-2" so I think that might be the problem.

I am going to work on it some more tonight, I will post if I make any progress.
Jim
Ya, its me, I am back again, thought you had gotten rid of me did you? Ya, finals week can take a lot out of you. Ok, so I playing around with this again, and I intalled the that rpm when I got the video monitors working, and if I type those commands again it tells me that its allready installed.
QUOTE
[root@x101-198-8-dhcp NV]# rpm -Uvh NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm
Preparing...                ########################################### [100%]
        package NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9 is already installed
[root@x101-198-8-dhcp NV]#

So I tweeked a bunch of stuff, unplugged the web cam (wich I think was confusing it) and I am finaly getting sound out of the card, but there as still a couple problems with it, like one it doesn't turn off the build in speakers when something is plugged into the headphone jack or the out slot and two the volume control doesn't work. I think that the problem has something to with ALSA being installed. If you agree with that, how would I go about un-installing it? Or any other ideas?
hughesjr
If you have alsa and oss installed, there are 2 mixers ... one of them is alsa the other is oss (actually there are several oss mixers, but they all adjust the same things). If you use the alsa mixer, you should be able to turn down those volumes).

I normally only install OSS (if it works with my soundcard)...I install alsa if OSS won't work.

How did you install alsa ... via rpms or by compiling the source?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.