Help - Search - Members - Calendar
Full Version: Kernel Not Mounting Root Partition
Linuxhelp > Support > Technical Support
Hey, I just got finished building my shiny new LFS (linux from scratch) distro, and am ready to start it up, but I have something configured/compiled wrong to where the kernel doesn't want to mount my root partition. Here's the entirety of the error problems I get (starting from the first failure to the KERNEL PANIC message):

03:04 rw=0, want=2 limit=1
EXT3-FS: unable to read superblock
03:04 rw=0, want=2 limit=1
EXT2-FS: unable to read superblock
03:04 rw=0, want=2 limit=1
FAT: bogus logical sector size 0
attempt to access beyond the end of device
03:04 rw=0, want=33 limit=1
isofs_read_super:  bread failed, dev=03:04, iso_blknum=16,block=32
kmnd failed to exec /sbin/modprobe -s -k nls_iso8859-1, errno=2
attempt to access beyond end of device
03:04: rw=0,want=64,limit=1
sh-2006: reiserfs read_superblock: bread failed (dev 03:04,block 128, size 512)
sh-2021: reiserfs_read_super: can not find reiserfs on 03:04
Kernel Panic: VFS: unable to mount root fs on 03:04
spurious 8259A interrupt: IRQ7.

As much as I get from that is that the kernel's going through filesystems trying to find one that works (the partition that I'm trying to load (/dev/hdb2) is ext3), but it doesn't find anything that works. I think what it's doing is looking for the wrong partition, because as far as I know dev 03:04 is the equivalent of /dev/hda4, which doesn't exist on my hda drive. So I guess what's going on is that the kernel is looking for the wrong partition for root, and I don't know why. I anyone knows how to pass an option to the kernel telling it to look for /dev/hdb2 rather than /dev/hda4 for root, it would be very helpful. BTW, I'm using grub (newest version, I think). Thanks,

in /boot/grub.conf, you should have an entry like this for LFS(this is from my redhat test machine):

title Red Hat Linux (2.6.0-0.test9.1.93)
       root (hd0,0)
       kernel /vmlinuz-2.6.0-0.test9.1.93 ro root=/dev/hda3
       initrd /initrd-2.6.0-0.test9.1.93.img

The root (hd0,0)<---{(hd0,0) is hda1 ... substitute your actual boot partition here} needs to be the location of the machines boot partition (not root partition) and you need to move the kernel (and initrd if you have one) to the boot partition ... then on the kernel line you need the path to the kernel (relative to the boot partition) ... and a root=/dev/hdb2
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.