Help - Search - Members - Calendar
Full Version: No Sound
Linuxhelp > Support > Technical Support
matthudd
Hi. I am a total Linux Newbie and have installed SuSe 9 on my gateway box with a 750 mhz Athlon and SoundBlaster PCI 128 sound card. Everything works great except for the sound. I have checked the ALSA web page. My driver seems to be correct. I have changed settings for the sound and everything other thing I can think of. My system dual boots with Windows 2000 and under Windows 2000, the sound comes out through my speakers just fine. Thus, I know the hardware works. I'm not ready to give up on Linux yet but I am at my wits end with this sound thing. Any help or advise would be appreciated.

Thanks
Joey
Hi,

Are there any error messages when you try and use sound? What are you trying to listen to? mp3s? cds? Have you tried it as root to see if theres a permissions problem?
matthudd
There are no error messages when I try to play a .wav or .mp3. There is nothing. When I went home for lunch I checked (Forgive me for not knowing the name) the properties and it said the driver was not active. I opened the Terminal, signed in as root and typed the "modprobe es1371" command and then it gave me a message that said somthing to the effect of I/O or IRQ (?) error and that I should check the system log. It said that the device may be configured wrong. when I get home this afternoon, I'll post the error message. Thanks for responding!
matthudd
OK here it goes. I tried to play an mp3 file with XMMS and the error says:

Couldn't Open Audio

Please check that
1. you have the correct output plugin selected.
2. no other program is blocking the soundcard
3. your soundcard is configured properly


Then I checked the SuSe Plugger. Under the "Driver" tab it says:

Driver Info #0:
Driver Status: es1371 is not active
Driver Activation Cmd: "modprobe es1371"
Driver Info #1:
Driver Info: snd-ens1371


So I go to the Konsole and do the following:

mattandsara@linux:~> su
Password:
linux:/home/mattandsara # modprobe es1371
/lib/modules/2.4.21-144-athlon/kernel/drivers/sound/es1371.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.21-144-athlon/kernel/drivers/sound/es1371.o: insmod /lib/modules/2.4.21-144-athlon/kernel/drivers/sound/es1371.o failed
/lib/modules/2.4.21-144-athlon/kernel/drivers/sound/es1371.o: insmod es1371 failed
linux:/home/mattandsara #

OK, so now what do I do?
hughesjr
post the output of the command:

lspci

That should tell us your Sound Card.
mode_flux
Hi, I'm having the same issues. I updated from Suse 8.2 ran fine to 9 now no sound. I ran lscpci & got this:
00:1f.5 Multimedia audio controller: Intel Corp. 82801AA AC'97 Audio (rev 02)
any suggestions?
matthudd
I wish I had an answer for you. I am still clueless as to how to get the sound to work. Until I can comeup with an answer, I have to boot into Windows to hear anything. If I try to open the Volume Control I get an error that says there is No soundcard available or sound support not configured yet. If I open Yast, It says i have es1371 driver for Soundblaster PCI 128 running. I don't know what's going on.

Sorry I couldn't be of more assistance.
hughesjr
matthudd:

I found this:
http://portal.suse.com/sdb/en/1999/04/cg_sbpci64.html
Troy Allen
I have the same problem with sound. The following was copied from SuSE website, but I can't figure out how to do this;
Your computer is equipped with a CDRW drive and one or several "ordinary" CD drives. After installing SuSE Linux 8.1, the CD drives cannot be mounted.


Cause


Some modules are missing from the initrd.

From SuSE Linux 8.1 on, the CD drive support is no longer compiled and kept in the kernel, but implemented by way of modules (cdrom and ide-cd). As opposed to the module ide-scsi, those modules (cdrom and ide-cd) are not included in the Initrd. That is why the SCSI emulation reaches all drives and not only those listed in the kernel parameter hdX=ide-scsi.


Solution


Insert the modules cdrom and ide-cd in the variable INITRD_MODULES in the file
/etc/sysconfig/kernel

To do this, open the YaST Sysconfig Editor. Select Base-Administration -> Common-Basics ->initrd_modules and insert both modules before the module ide-scsi. Be careful not to remove any of the modules listed, since they are necessary for booting.


Now, execute as root user the command mk_initrd

To do this, start a terminal program like konsole or xterm and log in as root user with the command su -. Then enter the command mk_initrd. If your boot manager is LILO, reinstall it with the commandlilo -v. This does not apply for GRUB. From SuSE Linux 8.1 on, GRUB is the standard boot loader.

Many Thanks in advance for anyone's help; Happy Holidays
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.