Help - Search - Members - Calendar
Full Version: Boot Problem
Linuxhelp > Support > Technical Support
I've managed to break my box. It just stalls at 'Loading Linux.....' when it boots. When I try the failsafe option it stalls at 'Loading Failsafe.....' This is immediately after the lilo selection box. I tried booting the mandrake cd as 'rescue' and it offer a repair mbr option. I tried this but got the following error 'Fatal: open /boot/initrd.img: no such file or directory'. Hope someone can help.

What were you doing right before this happend?
Mucking with my pc.

The whole story...

Tried to install some tools from the GNU Pic suite. RPM told me that I needed (I think) so I grabbed that and installed it. RPM prompted something about having to remove some files (I didn't pay as much attention to this as I should have). After some time my pc rebooted but only got as far as a prompt (something like Init_2.8#). I thought, ok, all I really care about is the stuff in /home so I'll just run the 'upgrade' option on the mandrake install cd and that should put back whatever I lost. That got as far as the installing boot manager, which it couldn't do. After that I got the 'Loading Linux.....' problem.
Update: another install of mandrake 9 in 'expert' mode sorted the problem. I now have a working linux install, my problem now relates to x. When I try 'startx' the screen blanks momentarily and then dumps me back at the console. The only thing I can make as an error from everything there is 'unable to find font 'fixed''
At this point, I would recommend that you save the important stuff in /home and wipe the install and start over ...

I don't recommend this lightly or often on Linux .... but your RPM database probably no longer reflects the actual RPMs installed on yuor system ... which means you will have major problems with installing RPMs from now until eternity.

Any changes to the kernel or glibc / libc are VERY dangerous .... those 2 programs (or packages, or whatever terminology you want to use) control the booting (kernel) and provide all the shared library files (libc / glibc) (windows geeks think c:winntsystem32 dll files...).

Actually, if you have a copy of the old kernel backed up ... glibc / libc is really the most important thing out there.

BUT on an RPM distrubution ... if the RPM database is lost, under most circumstances it's easier to start over...
Thanks guys, this site is great. I asked first over at MandrakeExpert and still haven't heard back. I'll take that advice and get /home backed up and start again. I'll try to pay more attention to what I'm doing in future....

Thanks Again. mellow.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.