Help - Search - Members - Calendar
Full Version: Mplayer
Linuxhelp > Support > Technical Support
I am new to linux and this fourm so I am not sure if this is an appropiate topic here.
I have been attempting to install Mplayer 1.0 or .92 ( I have tried both so far.) I have been using the RPMs at:
I attempt to install mplayer1.0-1.0-0pre2.6plf.i586.rpm
For this to work I need to install a few other things and I found everything but and
How can I get these installed so that I can finish installing Mplayer?
try adding this site as an update source like this (from the command prompt) (all one line):

urpmi.addmedia ftpmirror with ../

Then do :

urpmi.update -a

then do:

urpmi mplayer1.0 mplayer-gui
QUOTE (hughesjr @ Nov 24 2003, 11:07 PM)
try adding this site as an update source like this (from the command prompt) (all one line):

urpmi.addmedia ftpmirror with ../

Then do :

urpmi.update -a

then do:

urpmi mplayer1.0 mplayer-gui

I did what you said and the I type
urpmi mplayer 1.0 mplayer-gui I get the following.
[root@localhost fawkes]# urpmi mplayer1.0 mplayer-gui
unable to take medium "Updates for Mandrake Linux 9.1 (ftp1u)" into account as no list file [/var/lib/urpmi/list.Updates for Mandrake Linux 9.1 (ftp1u)] exists
One of the following packages is needed:
1- mplayer-gui-0.92-0.1plf.i586
2- mplayer1.0-gui-1.0-0.pre2.6plf.i586
What is your choice? (1-2) 2
To satisfy dependencies, the following packages are going to be installed (11 MB):
Is this OK? (Y/n) y
The following packages have bad signatures:
Do you want to continue installation ? (y/N) y
installing /var/cache/urpmi/rpms/libggi2-2.0.2-2mdk.i586.rpm /var/cache/urpmi/rpms/mplayer1.0-1.0-0.pre2.6plf.i586.rpm /var/cache/urpmi/rpms/mplayer1.0-gui-1.0-0.pre2.6plf.i586.rpm /var/cache/urpmi/rpms/libggi-2.0.2-2mdk.i586.rpm /var/cache/urpmi/rpms/xvid-0.9.1-2plf.i586.rpm /var/cache/urpmi/rpms/divx4linux-20020418-3plf.i586.rpm /var/cache/urpmi/rpms/libgii-0.8.2-3mdk.i586.rpm /var/cache/urpmi/rpms/libdivx4linux0-20020418-3plf.i586.rpm /var/cache/urpmi/rpms/libflac4-1.1.0-1mdk.i586.rpm /var/cache/urpmi/rpms/liblzo1-1.08-1mdk.i586.rpm /var/cache/urpmi/rpms/liblirc0-0.6.6-1mdk.i586.rpm /var/cache/urpmi/rpms/libdv2-0.99-3mdk.i586.rpm /var/cache/urpmi/rpms/libgii0-0.8.2-3mdk.i586.rpm

Preparing... ##################################################
Installation failed:
file /usr/lib/ from install of xvid-0.9.1-2plf conflicts with file from package libxvidcore3-devel-20030319-2plf
[root@localhost fawkes]#

What should I do about tge the error?
Thanks for your help, also I was wondering if you could explian what it was that I was doing with those three commands? Thanks agian
urpmi is the mandrake package manager, it solves dependancies and installs all the packages required for a given install.

The first command:
urpmi.addmedia ftpmirror with ../

Adds the site as a download source (the file list for the files is one level higher than the i586 directory and named, so the with ../ points to the file list.
The second command:
urpmi.update -a - updates urpmi (building a list of all files from all sources).
The third command:
urpmi mplayer1.0 mplayer-gui - solves the dependancies and installs all the packages required to install mplayer1.0 and mplayer-gui ...
The first error you have is that you have a problem with a media named ftp1u ... it looks like it used to be in the urpmi system, but is not any more.

The easy way to try and fix this is to use the command:

urpmi.removemedia ftp1u

This may not work because it looks like some files have been manually deleted ... if it doesn't work ... edit the file /etc/urpmi/urpmi.cfg and delete the section for ftp1u. It will look similar to this:

ftp1u ftp://some_path_to_get {
 hdlist: some name
 with_hdlist: some name
 list: list.contrib

It may or may not be in the file ... then go to /var/lib/urpmi/ and delete any files that contain ftp1u ... there may be some or all of the following:

list.ftp1u, names.ftp1u, and
The error that prevented installation is that the package libxvidcore3-devel-20030319-2plf (which seems to be already installed) conflicts with xvid-0.9.1-2plf (which is required for the mplayer install).

Do you know why you installed libxvidcore3-devel-20030319-2plf?

If not, you can remove it with the command:

rpm -e libxvidcore3-devel-20030319-2plf

If the package is required by another package, it will not unistall ... if it's not required, it will uninstall ... then you can redo the command:

urpmi mplayer1.0 mplayer-gui
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.