Help - Search - Members - Calendar
Full Version: Display Problem Dell 771mm Monitor/suse 8.2
Linuxhelp > Support > Technical Support
jevangelho
Hello All. This is my first post so please forgive me if this is done incorrectly. I have searched extensively for solutions to this, and this is my last resort.

For weeks I have tried running several Linux Distros on a Dell 4600c with a Dell E771mm Monitor. Try as I might, I can not bump the resolution up past 640x480. The Graphics Chipset is Intel 865g, which SUSE correctly detects, although it runs it with an Intel 810 Driver. THe problem arises when detecting the monitor. (E771mm). It isn't listed under the DELL models within the YAST Module.

I'm just basically extremely lost. Has anyone had this problem? Is there a way to edit a .config file somewhere? I have the exact specs of the monitor if that is needed.

Thanks so much to whomever replies to this....

Jason
hughesjr
Edit the file /etc/X11/XF86Config (the file may also be named XF86Config-4 ... if both are present, XF86Config-4 is used)and change the following parameters in the Section "Monitor" section...

HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0


(I obtained the refresh rates from HERE)
jevangelho
Thanks hughesjr. I'll try it immediately. (And hopefully you'll never hear from me again. haha) Thanks for the speedy reply.

Jason
jevangelho
Bad News. I tried doing as you said, but the XServer still defaults to 640x480 at the login screen.
The strange thing is that in the boot sequence before the xserver starts, the resolution is 1024x768. Editing the config file didn't work, and I was very careful to do it exactly as you suggested. It just wants to stay stuck in 640x480. Called Dell again and they said "We don't support Linux officially."

I want a screaming fast linux box so bad...

Jason.
jevangelho
sad.gif Bumping out of desperation. . .

A quick update: I have also tried this today with Mandrake 9.2. It picks up my monitor as a Dell E771mm (which is correct) but then when the Xserver kicks in it changes it to a generic "Vesa" monitor. What gives???
hughesjr
That is the wonderful SAX2 rebuilding the file ... is the /etc/X11/XF86Config file now switched back to different values for the frequencies?

I am still at work, once I get home I'll boot up in SUSE on my test box and see if I can figure out how to add a custom monitor to SAX2.
hughesjr
OK .. in SAX2 pick a dell monitor, then adjust the frequencies to the values I gave you. make the X=300 and the y=400 on the last page and use 30 - 70 and 50 -160 as the frequencies. That should fix the monitor.

I810 is the correct graphics driver for your video ... Here is the support intel page.
jevangelho
Before reading your follow-up, I tried installing Mandrake 9.2 as well as Fedora Core. Same universal problem with my monitor. I'm going to eagerly try your advice now :-)

Thanks so much. I'll let you know. And yes, the values were being rewritten. You rock.
jevangelho
Hughesjr;
Does the XF86Config file have to be edited as well (changing the refresh rates as before), as well as changing the specs in SAX2? I ask only because I am still having problems :-0
Thanks and Happy Turkey Day.
hughesjr
It shouldn't ... are the values I gave you for screensize and frequency in the new XF86Config file (generated by SAX2)?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.