Help - Search - Members - Calendar
Full Version: Apache Running But Not Responding
Linuxhelp > Support > Technical Support
unsure.gif I installed RedHat Linux 8.0 on a PC. I think its kernal 2.14.
Apache was installed with it, version 2.040 I think. I have started Apache with /usr/sbin/apachectl -k start
The error log /var/log/httpd/error_log said it was operating normally.

We are not using SSL, but the ssl_error_log gave warnings about RSA.

The Linux machine has a static ip. I was able to ping the server from my other machine. I tried browsing to it though, and it did not work. I typed the server's IP address into the browser URL line.

In the httpd.conf, I have set the Listen to 80 and ServerName to the server's (internal network) IP address. The error log does not show anthing to say anything wrong, the access_log stays empty.

Can anyone tell me why Apache is not serving.
First off, try to restart the server with /usr/sbin/apachectl restart . As far as my memory serves me, when you append the '-k' on the command line for a daemon, it usually stops the service, not starts. The second thing is, for arguments sake, try accessing the server on secure, that is, in the URL bar, enter in https://theip and see if you connect. It might be that apache is running in secure ssl mode rather then regular modes.
I tried It didn't work. If it is using SSL, how do I make it not use SSL?

The entries in the error_log are (including a restart):

[Time...] Apache/2.0.40 (Red Hat Linux) Configured -- resuming normal operations
[Time...] SIGHUP received. Attempting to restart
[Time...] Digest: generating secret digest authentication ...
[Time...] Digest: Done
[Time...] Apache/2.0.40 (Red Hat Linux) Configured -- resuming normal operations

And the entries in ssl_error_log are (these two warnings appear at the time I do a restart)
[Time...] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Time...] [warn] RSA server certificate is a CommonName (CN) 'localhost.localdomain' does NOT match server name!?

The other logs access_log, ssl_access_log and ssl_request_log remain empty.
Possibly since the
[Time...] [warn] RSA server certificate is a CommonName (CN) 'localhost.localdomain' does NOT match server name!?

this might be saying since the names dont match that apache
wont start....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.