Help - Search - Members - Calendar
Full Version: Modutils Installation For 2.6.0beta Upgrade
Linuxhelp > Support > Technical Support
ethan.mattor
mellow.gif
I am trying to upgrade my computer to Linux kernel 2.6.0-test9, but am stalled on one point. I keep getting the infamous "QM_MODULES: Function not implemented" message. After a bit of searching, I found that I needed to upgrade my modutils to the most recent version. I found the RPM package at the kernel.org site. I must say, being a bit new to Linux, it took me some time to figure out how to get the RPM file open (it was being placed under /usr/src/redhat/...). Next, I used "rpm -ba" to make the files and get them installed, but that didn't work so well. When I ran "/sbin/depmod -V" I kept getting "2.4.6-4". It took me some time to get the files installed in /sbin. However, now the version string is "2.4.21". Here's the bad part; I still get the error message "QM_MODULES: Function not implemented". I am at a loss as to how to proceed from here. Where should I be looking to straighten this problem out?

Thanks in advance,

Ethan.
hughesjr
http://thomer.com/linux/migrate-to-2.6.html

http://kerneltrap.org/node/view/799/3683

If you downloaded the RPM from here then that was the source RPM for the 2.4.21 kernel ... that you probably already had installed! What you want to do is install this via the instructions in the first link posted above....then run the ./generate-modprobe.conf /etc/modprobe.conf command as per the Modutils / module-init-tools section in link one above...

If this is an important box, you might want to backup your current modules.conf and create a 2.6 modules.conf then write a script that copies the correct modules file to modules.conf before the moddep command in your startup script...I could boot to the 2.6 kernel, but not the 2.4.21 kernel after I got finished.
----------------------------------
There is another approach here {README} ... RPMS for use with redhat 9 and rawhide/fedora.

I haven't used these yet...so I don't know if they work.
----------------EDITED .....-----------------

I did the RPM install...I downloaded initscripts-7.28-1.i386.rpm, modutils-2.4.25-10.i386.rpm, kernel-2.6.0-0.test9.1.93.i686.rpm, nfs-utils-1.0.5-1.i386.rpm, and mkinitrd-3.5.7-2.i386.rpm and copied them to a directory all by themselves and did the install like this:

rpm -Uvh *.rpm

reboot and all was well ... your mileage may very! (That was a lot easier than the other way! ... I didn't have to do anything to modules.config and everything {so far} seems to be working)...Except the NVIDIA video drivers (from the nvidia website) will not compile, but I am just using the nv non 3D drivers on this test box...
ethan.mattor
I figured out what I was doing wrong. When installing the files the instructions tell you to 'make moveold'. I figured that I really didn't care to back up my old files, as I was upgrading my experiment box, and didn't mind reinstalling the original distribution if the whole install went south. Well, that was a bad call. Upon careful reading of the messages during 'make install', I found several files that the routine refused to overwrite, so in effect did not upgrade. When I ran the 'make moveold' everything went smoothly. Isn't it funny how important it is to follow the directions? That lapse of reason cost me about a day, *sigh*. Thanks for your help!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.