Help - Search - Members - Calendar
Full Version: Red Hat 9.0 And Nforce Driver Problems
Linuxhelp > Support > Technical Support
linuxnewb
I just now started trying linux and I have a friend that absolutely refuses to help me. When I first ran Red Hat i had the Nforce drivers already and i double clicked them since im used to windows and auto installing things. I think I installed the wrong ones because my network card still wont show up and i cant revert back and when I tried to actually install the right way it says that a newer version is in use. Now i think I need to uninstall or something please help.
hughesjr
I think I would evalute my use of the word Friend if I were you laugh.gif

Need more info ...

what file did you double click (what was it's name and where was it located)...

Download the latest NFORCE drivers from the nvidia site ... what nforce chipset are you using? If you're not sure ... what is the model number and manufacturer of your motherboard...
linuxnewb
Well its NF7-S rev 2.0 Nforce 2 Chipset I have the latest drivers and it was the driver file that i double clicked on. "NVIDIA_nforce-1.0-0261.rh90up_2.4.20_6.athlon.rpm" thats the file but i just found out recently that im running 2.4.20_8 kernel for Redhat 9 and Nvidia doesnt have a specific driver for that kernel. Also i need to install the Nvidia Graphics driver but when i run the install it says that im running X server and that I have to shut it down. Need Help on this matter as well as Motherboard drivers problem. Any and all help will be appreciated greatly.
hughesjr
Download the following files to the /root directory:

kernel-source-2.4.20-20.9.i386.rpm

kernel-2.4.20-20.9.athlon.rpm

NVIDIA-Linux-x86-1.0-4496-pkg2.run (video)

NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm (chipset)

You will need the packages gcc and make installed as well ... type the commands to see if they are installed:

gcc -v
make -v

If either are not installed, install them.
------------------------------------------
First install the Kernel files (from a terminal window in the /root directory):

rpm -Uvh kernel-source-2.4.20-20.9.i386.rpm kernel-2.4.20-20.9.athlon.rpm

After this completes correctly, reboot and select the new kernel.
------------------------------------------
Now install the chipset driver with the following command:

rpm -Uvh NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm

reboot, setup the network card via Menu - System Settings - Network Device
------------------------------------------
Next, adjust the system so you can boot into Character based mode via this tip (except you will change the 5 to 3).

Now change the permissions on the video drivers file with this command:
chmod 755 NVIDIA-Linux-x86-1.0-4496-pkg2.run

reboot and login in character based mode as root, and issue this command:

IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-4496-pkg2.run

The program should build it's module. (After you answer all the questions).

If the module get built, edit the file:

/etc/X11/XF86Config

NOTE: Since you are in character based mode, you will need to use a charter based editor .. I recommend vi ... but you need to know how to use it before hand ... see these instructions.

Inside the /etc/X11/XF86Config file, you will need to change the driver from "nv" to "nvidia" and put a # infront of (to remark out) load dri and load gl-core ... add load glx (if it's not there). Here are more detailed instructions.

After finishing the edit, type startx. If this works, you can use the tip link (above) to boot back up in graphics mode.
linuxnewb
Thank You so much I will try as soon I as I get home from school.
linuxnewb
Okay i got the kernel to update. I also did the chipset drivers the way you wrote it down and my network card still hasnt shown up. Do i have to put in the values my self such as irq and what not? It says when i try to activate that "module nvnet could not be found".
hughesjr
After install of NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm, you should be able to issue the command:

modprobe nvnet

Which should load the network card driver. If it doesn't, try reinstalling NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm. This requires that you have booted to the kernel-2.4.20-20.9.athlon kernel.
linuxnewb
Once again you have helped me out I will try as soon as I return home after a party. one question though. When I installed should I have used the command rpm -i or rpm -Uvh this might be the key to my problems and If i reinstall will I have to force install.
hughesjr
either way should have worked ... now try -Uvh and it will tell you if it is already properly installed.
linuxnewb
I did the -Uvh command the first time. Now im just going to try and force install it because nvnet isnt showing up when i use the command modprobe
linuxnewb
Do I need to install to a certain directory. since nvnet isnt showing up anywhere in my folders at all. And If I need to what would be that command to install to a certain directory. Sorry Im really a newb to linux. The only things Ive gotten installed on Red Hat is XMMS and the new kernel.
hughesjr
No ... you only need to install the rpm...

Does the install of NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm complete without error?

Try the command:

uname -a
to make sure you are booting into the proper kernel (the new version you just installed)

It should look something like this:

Linux computername 2.4.20-13.8 #1 Mon May 12 12:37:55 EDT 2003 i686 i686 i386 GNU/Linux

(that is the info from one of my RH 8 servers)
-------------------
Also do the command:

find / -name 'nvnet*'
linuxnewb
No errors show up i will try the uname -a command but im pretty sure im booting into the 2.4.20-20.9 kernel which i installed since its the one that shows up on my boot up screen when i select os's. Thank You for your patience.
linuxnewb
Well i put in an old pci ethernet card into my box for linux and it recognizes it and installed it but now it says when I try to activate it, that It cant obtain ip information check cable.
hughesjr
Are you using DHCP or do you need to assign the IP address manually?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.