Help - Search - Members - Calendar
Full Version: Libstdc++-libc6.1-1.so.2 Error
Linuxhelp > Support > Technical Support
crgowo
I set up a file server for the first time using linux, trying to save the company money on microsoft fees. Anyhow, I was tying to get vnc installed and i got it unzipped and tarr but when i try and run the viewer i get this error.

[root@localhost vnc-3.3.7-x86_linux]# ./vncviewer
./vncviewer: error while loading shared libraries: libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file or directory

btw im using redhat 9 i downloaded off net.

What do i need to downloand and install to get it to work. I do a search for the libstdc++-libc6.1-1.so.2 and i get alot of links but non of which has a working download link. it always times out when i try and download the file. But all files i try and download are not named exaclty libstdc++-libc6.1-1.so.2.

Any help would be appreciated.
Thanks
hughesjr
instead of using the version you downloaded, use the vnc and vnc-server packages from redhat on the installation CDs. Use Menu - System Settings - Add/Remove Applications ... select the category Network Server and select VNC-Server (if you need vnc server) and Under the System Tools category select vnc.
crgowo
smile.gif didnt even notice there where there Thanks worked great.
hughesjr
Glad that worked...

The version you downloaded had been compiled with a different glibc ... the only other fixes would have been to either downgrade glibc (not a really option since everything else uses it), recompile the source code for the program yourself (a viable option, but now you have to track upgrades to this differently than all your RPMS), or see if it would run on the package compat-libstdc++ (a redhat 7.3 compatable glibc based on gcc 2.96).

Actually, the compat library contains the file libstdc++-2lib6.1.1.1-2.9.0.so that you might be able to link as libstdc++-libc6.1-1.so.2 if anyone has a similar problem with another program in the future.....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.