Help - Search - Members - Calendar
Full Version: Network Woes...
Linuxhelp > Support > Technical Support
thewoZa
Hi all - another newb quiestion! Sorry!

I am trying to get networking up and running on gentoo 1.4

PC 1 - Windows XP with a proxy & firewall - 192.168.0.1 (connected to the internet via usb modem)
PC 2 - Linux - 192.168.0.4

I have booted from the Install cd (1) and run net-setup eth0 and entered the correct values. Edited /etc/resolv.conf to nameserver 192.168.0.1
Edited /etc/hosts to include 192.168.0.1 server_name[I/]

My problem...

I can ping either machine from the other. When I [I]ping -c 3 www.google.com
I get the reply

"Pinging www.google.akadns.net (216.239.39.99)" ...

Host unreachable.

So name resolving seems to be working... Could be a firewall problem - disabled but no help.

The proxy on the windoze box has DNS Forwarding enabled (to my isp's dns server) and I am kind of stuck.

Windows to windows networking is fine and have had it running with Suse to windows so not a hardware issue...

Any help will be gladly received!!![I] wink.gif
hughesjr
If you did a ping www.yahoo.com from the gentoo box and got back an IP address, then (as you said) the name resolution is working correctly ... meaning that the network setup is working correctly .... at least, you have an IP address and a DNS server.

To see if there is a firewall issue (with a firewall installed on the gentoo box itself), use the command:

iptables -L

If you don't have any rules listed it will look like this:

CODE
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination


If you have something listed,use this command to remove all the rules:

iptables -F

You can use the command traceroute -n www.yahoo.com to see if your packets are making past your internet router/proxy.
thewoZa
Thanks for your advice but iptables were empty and now I am unable to resolve names on the linux box again. Maybe I'll try another distro but I have heard good things about gentoo...
hughesjr
Gentoo is a pretty good distro ...

Are you still booting from the boot disk and doing your install ... or booting to your own kernel?

If on your own kernel, go to directory /etc/conf.d/net and add the following info:

CODE
iface_eth0="192.168.0.2 broadcast 192.168.0.255 netmask 255.255.255.0"
gateway="eth0/192.168.0.1"


and in /etc/resolv.conf it should look like this:
nameserver 192.168.0.1

If this is happening while in the chroot during install, make sure you have copied the /etc/resolve.conf to /mnt/gentoo/etc before you do the chroot command ... or go to Alt-F2 and login as root .... and copy it from there. (in order to login to the other terminals when booting from the install cd, do a passwd and reset the root password on the bootup before doing the chroot)

If all that is good ... are you loading your network card module? What network card are you using and do you know the module name?
--------------------------------------
A nice trick during install of Gentoo that I use (after your network card is working)... login to Alt-F2 as root and use the command:

lynx www.gentoo.org

Now use your arrow keys to navigate to Installation: Gentoo Linux/x86 and press enter. Now you can read the instructions by pushing Alt-F2 and go back to the install by pushing Alt-F1. Use the arrow-keys to navigate ... and press enter to follow the selected link...
thewoZa
Thanks for the advice.

I am still at the initial stages of install as no point going further if i can't get the network up and running and have only booted from the cd and run net-setup eth0 and edited /etc/resolv.conf, /etc/host and /etc/conf.d/net (both are as you say they should be except for the linux ip is 192.168.0.4 and /etc/host reads 192.168.0.1 server). The network card is the integrated nforce2 one (epox 8rda+).

I can now resolve names again but still get no reply. Traceroute is an unknown command apparently. How would I use this command.

Thanks again.
thewoZa
Have tried to ping www... from windows clients and this not working either. Gues my firewall or proxy isn't set up correctly. Have tried with the firewall disabled and still no reply. Must be the proxy??

ICS is off as is the windowsxp firewall so I guess it must be. Will fiddle with settings and see what I can come up with.
hughesjr
traceroute is probably not on the boot disc .... some routers on the internet don't allow ping, so www.yahoo.com may not be pingable from your location.

You can use this command from XP ....

tracert -d www.yahoo.com

the result will look something like this:

CODE
C:>tracert -d www.yahoo.com

Tracing route to www.yahoo.akadns.net [216.109.118.70]
over a maximum of 30 hops:

 1    <1 ms    <1 ms    <1 ms  192.168.0.1
 2     9 ms     9 ms     7 ms  10.98.64.1
 3     8 ms     6 ms     7 ms  24.170.32.37
 4     8 ms     *        8 ms  24.170.32.125
 5    12 ms    11 ms    11 ms  24.93.33.229
 6    13 ms    13 ms    13 ms  24.93.33.161
 7    15 ms    13 ms    11 ms  66.185.133.145
 8    16 ms    11 ms    12 ms  66.185.150.148
 9    18 ms     *       19 ms  66.185.152.132
10    20 ms    20 ms    18 ms  66.185.133.97
11    21 ms    19 ms    18 ms  66.185.133.190
12    18 ms    21 ms    26 ms  209.244.15.165
13    51 ms    51 ms    49 ms  64.159.0.138
14    51 ms    52 ms    49 ms  64.159.18.67
15    52 ms    51 ms    52 ms  63.210.59.254
16    51 ms    52 ms    71 ms  216.109.120.142
17    61 ms    51 ms    69 ms  216.109.118.70

Trace complete.


Using the trace from your location, try pinging any of the sites outside your network ... I think your card is setup OK if you can do name resolution and ping internally ...
-------------------------------------
What trace route does is basically print each hop (or router) it touches on it's way to a location ... sending back 1 reply for each new router (hop). ... in windows -d (and in linux -n) makes it so you don't have any name resolution on the IP's for the hops. If you want names (the command takes much longer to run), remove the -s (or -n) switch. SO...the command for Windows is tracert -d www.yahoo.com and for linux (if traceroute was installed) would be traceroute -n www.yahoo.com.

Many routers on the internet turn off ICMP traffic ... and if/when you hit one ... nothing works past that point. Your ICS may have ICMP disabled.
thewoZa
Can ping/tracert from windows host but not from windows clients so ISP must allow ICMP. I will carry on with the install and see if I can access the net from the linux box.

Is export http_proxy="http://192.168.0.1:port_no" the right command for setting linux to use this proxy?

Thanks again for the help.
hughesjr
If you are using a proxy server (if you have to put info in internet explorer on a windows machine), then the same ip address and port that you use in explorer under lan connections, you would use like this:

export HTTP_PROXY=192.168.0.1:port_num

(notice there is no http://)

However, if you are not using a Proxy server ... but just NAT, then there is no need to set up the proxy server variable....
thewoZa
Thanks for the info. I will have a go and let you know how I get on.
hughesjr
Also, if you need to setup a proxy as part of the gentoo setup ... you will need to do it when you first login (before the chroot) and just after you do the chroot command.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.