Help - Search - Members - Calendar
Full Version: Duel Boot Mystery?
Linuxhelp > Support > Technical Support
u05rdh
I have installed Red Hat 9.1 and had the partition and everything went fine.

When I turned on my PC it would come up with the windows dos type screen allowing me to choose Windows XP or Red Hat 9 and I had 27 seconds to do so. Windows being the default.

Now when I turn on the pc I'm getting a linux screen showing me Red Hat 9 and Dos? If I select Red Hat 9 then all goes fin and It boots if I choose Dos it then goes to the above windows screen where I can choose Windows XP or Red Hat 9.

How do I get rid of the linux screen and just have Windows xp or Red Hat 9 choice only?

Thanks for any help

Richard
u05rdh
How would I just change the Linux boot screen to display Dos first?

Can the boot sequence be edited so that Linux is not the default?

Thanks

Richard
hughesjr
First, yes you can edit the Linux screen to default to Windows like this:

When booted up in Linux and logged in as the root user, go to the directory /boot/grub and edit the file grub.conf.

Inside the file there are title lines ... each title line begins a different selection in the menu. There is also a default= line. The number in the default line corresponds to a specific title line ... to boot to the 1st title use default=0 ... to boot to the 2nd title use default=1 ... to boot to the 3rd title (if there is one) use default=2, etc.

Also inside the grub.conf file there is a line that says timeout=xx where xx is the number of seconds to wait ... you can adjust that to change the wait time that the selection screen is displayed. My file has timeout=5

After making changes to the grub.conf file, save it.

----------------------
Second ... now that the (Master Boot Record) MBR of your PC has changed to having grub as the bootloader instead of using the windows bootloader, it is probably better to leave it that way for now. Changing the bootloader back involves booting with the Windows XP CD and using the repair console ... kind of dangerous.

The better option (now) is to make the second selection menu disappear ... it is easy and less dangerous. You can change it like this:

1. When booted up in XP, open Windows Explorer and go to your C: drive in the directory. If you see a file called boot.ini then you can proceed to the step 3... if you don't see a file named boot.ini then you need to adjust Windows Explorer to see hidden files (step 2).

2. To view hidden files in Windows Explorer, select the Tools menu option and then select Folder Options. Select the View tab an you will see the following image.


Adjust the permissions to select Show hidden files and folders and uncheck Hide extensions for know file types and uncheck Hide protected operating system files.

3. Go to c: and right click on the file named boot.ini and select properties. Uncheck the box Read-Only and press OK to exit the properties dialog. Right Click on the file again and select copy, then paste it in C: and you should have a file named Copy of boot.ini (as a backup of the boot.ini file before changes).

4. Double Click on the file boot.ini and it should open up in notepad. The contents will look something like this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /fastdetect

c:linuxboot.xxx linux

remove the linux line from the file and save it (you can also adjust the timeout=xx to change the seconds to wait for selection).

If there is only one selection, then XP won't show the selection window ... it will just boot...
-------------------------------
Make sure to save your Copy of boot.ini file in case you shift your MBR back to windows XP (re-installing XP will do that, for example...also see below).
-------------------------------
If you would rather change your MBR back to boot from XP instead, look at this thread concerning booting from the windows XP cd and doing the work from the repair console. You would not change your boot.ini file but would do the repair console instead...
u05rdh
I can't get access to the grub.conf file it says I don't have permission?

How do I log in as the root user and edit the file?

Richard
hughesjr
when you log in, use the username root and the password that you entered for the root user when you installed the system.

If you don't remember your root user password, you can change it by booting into single user mode and typing the command:

passwd root

it will prompt you for the root users new password.

If you need to get to single user mode in redhat 9, when at the initial grub menu (where you select to boot to linux or windows in linux)...highlight the Linux boot line using the arrow keys, and then press e to edit. Now move to the kernel line and then press e agian to edit the kernel line ... at the end of the kernel line, add a space by pressing the space bar and then the number 1, so if your kernel line was:

xxxxxxx

it would now be

xxxxxxx 1

then press the enter key and when back at the grub menu press b to boot in single user mode...

when at the prompt, type the command passwd root and press enter ... then type the new root user password. After changing the root user password, press alt-ctrl-del to reboot the machine.

After reboot, login as root (using root as the username and the new password as the password).
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.