Help - Search - Members - Calendar
Full Version: Permissions Of Mounted Folders
Linuxhelp > Support > Technical Support
frodo44
Hey, I'm having a problem with my mounted FAT32 partitions where I can enter them from root, but not from my other account, even though it has root privileges too. I've tried changing permissions in every way that I can think of, but I still can't enter the directory, even though the user has read priviliges. Any ideas? Does it maybe have to do with the fact that it's a mounted FAT32 partition? Any ideas would be helpful.

Thanks,
Eric
michaelk
Make sure the directory that you mount the FAT32 partition to has read / write permissions as desired unmounted. Then make sure the umask option is set correctly in the fstab file. Remember it is backwards from what you would use with the chmod command.

umask=000 means read / write for all users.

Are you using any other option like suid in fstab?
frodo44
I'll have to say that was all greek to me. Here's it's line in the fstab file:

CODE
/dev/hda3        /e               vfat        defaults         1   0


So, would I put umask=000 in place of defaults? Also, I have no idea what the suid is...
I checked the /dev/hda3 file, and set its permissions to read/write for everyone, with no execute priviliges, since there are no linux executables on it. Thanks for the help.

Eric
frodo44
All right, that helped... Thank you very much for your help.

Eric
hughesjr
Just for future searchers .... umask is a setting in your users profile on Linux ...(usually set in each users home directory in a file called .bash_profile).

The default setting is 002 ...

umask is a "User Mask" that subtracts from standard file creation permissions ... if the standard permissions are rw-rw-rw- (or 666) then 002 is removed, making the file creation permissions 664 (or rw-rw-r--)...if you change your umask to 022, then the file creation permisions would be 644, etc.

To change the umask for a given user, edit that users .bash_profile and add (or edit) a line that says:

umask=002

to whatever you want it to be.

With some versions of Linux (and UNIX) it is better to use an extra zero in the beginning ... like this:

umask=0002

or

umask=0022

I always use 4 digits...the first digit is just a placeholder.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.