Help - Search - Members - Calendar
Full Version: Boot Problem
Linuxhelp > Support > Technical Support
Hi linux gurus. I'm new to linux but have decided to take the plunge. I have installed Redhat 7.0 but I can't get it to boot (sound familiar) I have a dual boot system running Win98SE. I have installed a second hard drive especially for linux. Both hard drives are on the primary IDE channel (Windows on hda and linux on hdb). I have formatted my second hard drive with native linux using Partition Magic and created 3 partitions. /boot (100meg) , / (5.5gig) and swap (500megs). Everything seems to install correctly, Disk Durid finds my partitions on hdb and does the format without reporting any problem, Xconfig found my vid card and my monitor and tested OK. I continue with the install and after all the packages are finished loading I'm prompted to reboot. I reboot, lilo fires up with the choice of Windoze or Linux, I choose Linux and that's about as far as we get. The system locks up and I'm stuck. I've tried a ctrl X at the lilo menu and then typed linux at the command prompt. Again it just locks up.

What am I doing wrong? does /boot have to be on hda? or am I just really stupid :-) /boot is the first patition on hdb so I don't think linux should have any trouble finding it.

This is very strange. Do you have lilo installed in the master boot record? Does the screen just go blank after you hit enter on the boot prompt? Or are you given any output to the screen whatsoever? Did you make a boot disk in the install to try and boot the system with? I know that there was a particular version of Lilo that caused me problems in Debian (potato) that caused my system to freeze when i tried to boot it from lilo. Once I installed an updated version of Lilo, everything was fine.
Hi Tourettes

The failure made changes a little each time but basically it's the same. If I try to launch linux from the lilo's graphical screen I get typically

Loading Linux.._

Then the machine just stops with the cursor flashing and will stay there until I get bored and reboot. If I do a crtl x then type linux I get a similar problem and sometimes the machine will reboot itself. But once the process went a little further before crashing and this may be a clue for the gurus. I did a crtl x and typed linux at the command line and obtained the following info:

Boot: linux
Loading Linux............
Uncompressing Linux...

crc error

--system halted

This begs the question...what's a "crc" error? (maybe it means I should oil the machine :-)

In answer to your questions

1.Yes Lilo is on the MBR
A CRC error on a kernel? What the fsck! This is the first time i've seen this, I have only seen crc errors with compressed archives (which is essentially what a kernel image is).

According to this post it's caused by a bad zImage (or bzImage). If this is a stock kernel (that is was installed by the distro's installer) then you will probably have to download a new iso and burn off the cd again. It looks to be un-fixable sad.gif That sometimes happens with any compressed file on any platform.
If my memory of CRC's are correct, they are checksum errors, and crc errors occurs when either the file has changed (virus or bad sector on the hard drive). In linux, unless you got a worm, its most likely a bad hard drive.
I suppose this is possible, but when I formatted the drive I asked Disk Durid to check for bad blocks and it found nothing. I'll check again though thanks for the tip.

I have two releases of REDHAT (6.2 and 7.0), they both crap out, so maybe the disk is sad hmmmm, I hate it when that happens :-)

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.