Help - Search - Members - Calendar
Full Version: Red Hat9 And Xp Sharing Fat32 Partition
Linuxhelp > Support > Technical Support
ahilliar
I currently have Windows XP pro and Red hat 9 installed on same 80 gig hd. hda1 is xp and is NTFS, while hda6-8 are linux. hda5 is a 10gig fat32 partition in between. I was able to save files to this partition and access them from either xp or red hat, but now for some reason in xp I cannot access anything, and when I save something to the partition from either os I cannot access from the other os.

In fact in xp it shows the partition as having total space of only 9.7gig with an available space of 9.7, while in partition magic and linux it shows the partition as being total of 10gig, with 9.7 available and .3 taken up, which is right, there are pictures and .wav files on it.

In red hat it automounts to /mnt/share. I had edited the /etc/fstab file to set this up, but had later deleted the line, not wanting it to automount anymore...but it still does for some reason. When I first edited /etc/fstab I got a warning message:
[mntent]: warning : no final newline at the end of /etc/fstab

The line I had added to fstab:
/dev/hda5 /mnt/share vfat auto 0 0

Here are my permissions on /mnt/share:
user, group, others can all read, write, enter
ownership-
user: root
group: root
I do not have the box checked that says something like "the above are applied to all filesystems and folder within"

Here are my permissions on /dev/hda5 (which is the partition that gets mounted to /mnt/share):
user, group can read, write, and enter
ownership-
user: root
group: disk

The above info comes from right clicking on the /share or /hda5 icons in konqueror, and I believe these settings are the same as they were when I first installed except for write being enabled on /hda5.

I must admit, the distinction between permissions for /mnt/share and /dev/hda5 somewhat escapes me, and I do not really know what the ownership category really means. How would it be possible to have write access to the partition itself, but not the directory where the partition is mounted, or vice versa?

I want to be able to use hda5 (fat32 10gig partition) as a partition where I can save files from either xp or red hat and be able to access them in either os, and for a while I was. I am not 100% sure, but I think this recent trouble has only happened after I tried to edit /etc/fstab.

Please help
hughesjr
try this line instead in /etc/fstab:

/dev/hda5 /mnt/share vfat defaults 1 2

(make sure to press the enter key at the end of the last line of fstab...)

issue these command to setup the share directory:

chmod 777 /mnt/share

Then reboot and see what happens.
ahilliar
Ok, a few things happened:

1) previously I had about 300MB worth of jpegs on the 10gig FAT32 partition, now I do not see them in either xp or red hat, but both OSs show the partition as only being 9.7 gig. So the jpegs are still there taking up space but I cant see them anywhere

2) I can write to the partition in xp and read that data in red hat and vice versa, which is good. But I can only write to it in red hat while logged in as root, which is bad. I want all users to have read and write priveleges.

Here are permissions on /mnt/share:
user can show and write entries, and enter
group and others can show entries, and enter
for ownership user and group are set to root

Here are permissions on /dev/hda5:
user and group can read, write, and exec
others can do none
for ownership user is root, and group is disk

What is the distinction between show entries, write entries and enter
and read, write, and execute as the permissions categories? And what does the ownership info really mean?

When I tried to change the permissions on /mnt/share while logged in as root so that group and others can write entries and enter it didnt work. Whenever I closed the permissions box and reopened it the settings went back to what I described above. Does it even matter anyway since under ownership both user and group are root?

Thanks
ahilliar
I have to apologize, I should have researched more before writing this long ass post. I have just discovered chmod and have been able to solve almost all problems. Only one remains, I still cannot write to /mnt/share unless logged in as root even though I thought the 'default' option in fstab line allows rw access to everyone.

Here is what happens when I try to change permissions on /mnt/share (when logged in as root)-

% ls -l /mnt

(of course there are other directories in /mnt but they dont matter for this)
drwxr-xr-x 13 root root 4096 Dec 31 1969 share
(it strikes me as strange that this directory was created Dec31 1969)

% chmod go+w /mnt/share

chmod: changing permissions of '/mnt/share' (requested: 0757, actual: 0755) : Operation not permitted

Why would it not let me change write permissions for group and others even when I am logged in as root?

Thanks for the help
hughesjr
prior to mounting (or do umount /mnt/share), then do the command

chmod 777 /mnt/share

Then remount ...

It is strange that 12/31/69 is used as a date ...
ahilliar
I already issued that command while umounted and it worked, but only for when the partition is unmounted: when /mnt/share is unmounted permissions are drwxrwxrwx, but when mounted, permissions are drwxr-xr-x.

When I try to issue the command:
chmod 777 /mnt/share
while /mnt/share is mounted it says I dont have permission to do so, even though I am root.

So is there some kind of rule that only root can write to a mounted partition, but while its unmounted anyone can?

-Thanks
michaelk
For read / write for all users add umask=000 in your /etc/fstab file. chmod does not have any effect on a VFAT mounted partition because VFAT does not use file permissions like linux.

/dev/hda5 /mnt/share vfat defaults 1 2

Should be

/dev/hda5 /mnt/share vfat user,umask=000 0 0

See man pages for mount and fstab for a description of possible options. The user options allows any user to mount / umount the filesystem.

The reason you really do not want to use anything other then 0 0 for a vfat partition is that the very last 0 tells fsck to ignore checking the filesystem at boot. fsck support AFIK as not been perfected and could possibly corrupt your FAT32 partition.
hughesjr
RedHat has recommended using values of defaults for mntops(the fourth field), 1 or 2 for dump (the fifth field), and 1 for fsck( the sixth field) since redhat 7.3 for vfat partitons [I don't often mount vfat partitions...so if there is a problem with the latest version of fsck.vfat then I don't know about it, although it is still listed as alpha]. If you don't use dump (or don't care to dump the vfat file system) then a value of 0 for dump is OK ... you could also use a value of 0 for fsck if you want ... umask=000 is a good option to make the mount ... and so is user (if you want users other than root to mount the filesystem), so I guess the best options would be:


/dev/hda5 /mnt/share vfat rw,suid,dev,exec,auto,user,async,umask=000 0 0

or if you want to set dump and fsck then this:

/dev/hda5 /mnt/share vfat rw,suid,dev,exec,auto,user,async,umask=000 1 2
ahilliar
I see...so basically the only user who can write to a mounted filesystem is the user who mounted it, and since I could only mount /mnt/share using root...

I have read the man pages for fstab and mount, but some of the content is still chinese to me, and I havent had much time to digest yet.

Thank you very much for your help
hughesjr
if you mount with the umask=000 it shoul dshow up as 777 instead of 755...
michaelk
hughesjr,
Tnx for the update
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.