Help - Search - Members - Calendar
Full Version: Jvm Plug-in For Mozilla (red Hat 9)
Linuxhelp > Support > Technical Support
untz
Hello,

I downloaded the JRE 1.4.2_02 from http://java.sun.com and when I ran the installer, the JRE was installed in /usr/java/jre1.4.2_02/

Now when I go to:

http://games.yahoo.com/games/downloads/sg.html

A dialog box appears stating:

"This page contains information of a type (application / x-java-vm) that can only be viewed by the appropriate plug-in."

I am running Mozilla 1.2.1 on Red Hat 9.0.

If anyone can help me with this problem, I would be very grateful.

All the best,

Unnsse
Joey
You have to add a symbolic link to java in the mozilla plugin directory.

Have a look at http://plugindoc.mozdev.org/faqs/java.html#Linux
untz
On my Red Hat 9.0 Linux distro, (logging in as root), my JRE Plug-in is located in:

/usr/java/j2re1.4.2_02/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

My Mozilla 1.2.1's plug-in directory's path is:

/usr/lib/mozilla-1.2.1/plugins

I followed the instructions from the link in the previous post by:

> cd /usr/lib/mozilla-1.2.1/plugins
> ln -s /usr/java/j2re1.4.2_02/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

Now, I wrote a HelloWorldApplet.java & an HelloWorldApplet.html file and
compiled the applet with the javac compiler.

When I run the appletviewer like this:

> appletviewer HelloWorldApplet.html

The simple HelloWorldApplet works...

But however, if I open the HelloWorldApplet.html file using Mozilla, the same
error message from the first post appears...

I also went to Yahoo! Games and I keep getting the same error...

If anyone can help, it would be greatly appreciated....

-Unnsse
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.