Help - Search - Members - Calendar
Full Version: Can Linux In Dual Boot Affect Usb Detection In Xp?
Linuxhelp > Support > Technical Support
I just recently installed red hat 9 into a dual boot system with my already installed xp pro. Everything went great and red hat is running fine but all of a sudden in xp USB devices are not detected. I have a scanner and digital 8 track recorder that I all of sudden cannot use. Would the Linux install have anything to do with this? This problem did not occur until the day after my linux install.
I have tried multiple USB cables, I have the newest USB drivers and xp sp1a installed already.

My specs:
maxtor 80gig hd
athlon 2200 xp+ cpu
epox 8rda+ motherboard
geforce mx440se vid card
To be honest with you, I cannot see any possible conceivable way that a linux install would affect USB devices in Windows. Are your USB ports on board, or are they provided by an expansion card? Check and make sure that any usb expansion cards are plugged firmly into their slots. While in windows, unplug and plug back in your USB devices.
I also don't see how a linux install can affect USB detection in Windows XP ...

Did you recently add hardware that required you to use the Windows XP disc for drivers ... sometimes a service pack may need to be reinstalled after older drivers are used...

Did you adjust any of your BIOS settings during the Linux install?
Yeah I didnt think my linux partitions could affect my xp partitions, I didnt alter any BIOS settings during linux install except to boot from CD-ROM which was specifically for the install, and I have not addded any hardware.

Xp is suppossed to autodetect usb devices, specifically my 8 track should show up as a removable drive, but it doesnt. But, i am able to mount it in red hat and get to the files that that leads me to conclude that there is a problem with xp, or some setting in xp, not my actual usb ports as I first feared.

This happened before, xp not detecting usb devices I mean, but I didnt have linux yet. That time the problem was fixed (I guess) after I changed the setting on my thermaltake volcano 9 cpu cooler back to "smart" from "manual." Epox support (my usb ports are on board epox 8rda+) said that the cooler was sucking too much power on the manual setting and so the usb ports weren't able to work. That sounded like a cop out answer to me, and I guess I was right, assuming this new occurence of the same problem has the same cause. It must be something in xp but I have no idea what it could be, I have all the newest drivers and sp1a installed.

So I am left with a decision for the time being... access the files via linux and move them to my fat32 partition where I can access them from my windows based music editing program (Sonar), or find a comparable linux music editing program................
Any suggestions????????
There are many recording packages in Linux ... here are a couple:

cinelerra (video processor ... but can be used for just audio (with 6 input channels).

Whether these will work with a USB input device, I don't know....
Thanks, they dont really have to work with a usb device, the software just has to able to use .wav files.
The problem with the usb device is not within a windows based editing program, but (I guess) something in xp itself. The fact that I can mount and access the device in linux basically gives me a removable drive w/ a bunch of .wav files on it.
I think I may have figured out a possibility for why I havent been able to use usb devices in xp.
In linux my usb 8track mounts from /dev/sda to /mnt/mr8. I checked the permissions for /dev/sda and others could not read, write, or execute. Maybe this is why xp couldnt autodetect usb devices.

I also discovered that if I mount /dev/sda to /mnt/mr8 in linux and logout w/out unmounting, then xp detects the 8track. But if it is unmounted in linux, then xp still cant see it. I was thinking of adding this line to /etc/fstab-

/dev/sda /mnt/mr8 auto auto,user,rw 0 0

I figure that way it will always be mounted, but:
1) if my 8track is not plugged into usb port will Linux freak out when it tries to mount it?
2) if I boot up straight into xp will I still not be able to see the usb devices since linux hasnt had a chance to mount yet?

Thanks for all your help
When you boot into XP (on a dual boot machine) all the usb devices (and all other devices on the PC) are reset ... so to the devices, Linux doesn't exist at that point ... just like when you boot in Linux, it doesn't matter if you have a Windows sound card driver, your sound card will work if you have a linux driver ... One OS doesn't have anything to do with the other functioning [unless you are running something that runs both OS's simultaneously (virtually) and switches between OS' VMware.]
Ok, but if I add that line to fstab (which would mount /dev/sda) on start up, will Linux freak and abort the start up or anything if there is no device plugged in?

And I've tried it a few times; if I mount /dev/sda to /mnt/mr8 in linux and logout w/out unmounting, then xp detects the 8track. But if it is unmounted in linux, then xp still cant see it.

After doing some research, It is possible on a soft reboot (with the PC power remaining on), that some external peripheral devices will not reset. This doesn't have anything to do with the OS being used ... but it could affect devices.

Try an experiment where you do a full shutdown and wait 5 seconds and reboot compared to a soft reboot and see if there is any difference...(with and without unmounting the device).
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.